Bug 847935 - [abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
[abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
abrt_hash:68739559b9643a486bd58a742bf...
:
: 867410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 01:38 EDT by Mikhail
Modified: 2013-02-23 02:36 EST (History)
39 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 19:51:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: usr_share_xorg_conf_d.tar.gz (1.55 KB, text/plain)
2012-08-14 01:38 EDT, Mikhail
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (381 bytes, text/plain)
2012-08-14 01:38 EDT, Mikhail
no flags Details
xinput list --long (10.23 KB, text/plain)
2013-01-30 10:24 EST, Fabien de Saint pern
no flags Details
evemu-describe /dev/input/event9 - Microsoft Microsoft® Nano Transceiver v2.0 (1.32 KB, text/plain)
2013-02-01 08:48 EST, Fabien de Saint pern
no flags Details

  None (edit)
Description Mikhail 2012-08-14 01:38:26 EDT
Description of problem:


Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.2-4.fc17

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
kernel:         3.5.1-1.fc17.i686.PAE

backtrace:
:0: /usr/bin/Xorg (xorg_backtrace+0x4a) [0x80ac24a]
:1: /usr/bin/Xorg (0x8047000+0x4523d) [0x808c23d]
:2: /usr/bin/Xorg (0x8047000+0x45f5b) [0x808cf5b]
:3: /usr/bin/Xorg (GetPointerEvents+0x117) [0x808e3e7]
:4: /usr/bin/Xorg (0x8047000+0x16e75d) [0x81b575d]
:5: /usr/bin/Xorg (miPointerWarpCursor+0xdc) [0x81b5b4c]
:6: /usr/bin/Xorg (0x8047000+0x7e3f6) [0x80c53f6]
:7: /usr/bin/Xorg (0x8047000+0x16f01f) [0x81b601f]
:8: /usr/bin/Xorg (0x8047000+0x108f51) [0x814ff51]
:9: /usr/bin/Xorg (0x8047000+0xf4277) [0x813b277]
:10: /usr/bin/Xorg (RRPointerScreenConfigured+0x86) [0x813b456]
:11: /usr/bin/Xorg (RRTellChanged+0xdf) [0x8134ddf]
:12: /usr/bin/Xorg (RRCrtcSet+0x1e8) [0x8135d38]
:13: /usr/bin/Xorg (ProcRRSetCrtcConfig+0x448) [0x8136eb8]
:14: /usr/bin/Xorg (0x8047000+0xed3ae) [0x81343ae]
:15: /usr/bin/Xorg (0x8047000+0x303fd) [0x80773fd]
:16: /usr/bin/Xorg (0x8047000+0x1dce5) [0x8064ce5]
:17: /lib/libc.so.6 (__libc_start_main+0xf5) [0x4823c635]
:18: /usr/bin/Xorg (0x8047000+0x1e029) [0x8065029]
Comment 1 Mikhail 2012-08-14 01:38:30 EDT
Created attachment 604140 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 2 Mikhail 2012-08-14 01:38:32 EDT
Created attachment 604141 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 3 Mikhail 2012-08-14 12:55:35 EDT
Switching between monitors

Package: xorg-x11-server-Xorg-1.12.2-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Damien Grassart 2012-09-02 20:05:31 EDT
Switched a game (Heroes of Newerth) to use fullscreen.

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Pawel 2012-09-03 06:53:05 EDT
I have unplugged an extarnal display

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Andrey V. Henneberg 2012-09-03 08:39:55 EDT
This issue is appeared when I switch on doublehead mode using xrandr:
xrandr --output VGA1 --mode 1360x768 --pos 1024x0 --output LVDS1 --mode 1024x600 --pos 0x0


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Andrey V. Henneberg 2012-09-04 09:29:28 EDT
This issue appeared when I connect an external display to my netbook using xrandr:
xrandr --output VGA1 --mode 1360x768 --pos 1024x0 --output LVDS1 --mode 1024x600 --pos 0x0


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Andrey V. Henneberg 2012-09-05 03:35:57 EDT
X Server has been crashed on user logon

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Cristian Paslaru 2012-09-06 12:29:14 EDT
Hi,

This happens all the time when I change the display resolution, and this is usually done when I add/remove an external display on my laptop.

Thanks.


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 ulferik 2012-09-07 02:40:40 EDT
Ongoing	possibly energy saving	

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 thohai 2012-09-10 04:47:42 EDT
Happens everytime at boot with Lenovo X201s F17 (all updates as of Monday 10th September 10:41 GMT+2)

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 thohai 2012-09-19 05:20:04 EDT
Happens on every boot

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 James B 2012-09-23 06:23:24 EDT
I noticed this problem on boot up. System notification

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 frizi09 2012-09-23 14:58:52 EDT
On boot with gnome-shell

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 ulferik 2012-09-24 03:26:16 EDT
Can't get problem data from abrt-dbus: GDBus.Error:org.freedesktop.problems.InvalidProblemDir: '/var/spool/abrt/xorg-2012-09-24-09:22:48-748-26' is not a valid problem directory

It is still an Xorg problem.


Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 StephTech 2012-10-12 22:59:38 EDT
I don't know what happened. It crashed the other day when I was trying to use dual screens with my tv. I tried to send this report then, and it crashed also...

Package: xorg-x11-server-Xorg-1.12.3-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Grant Murphy 2012-10-15 06:43:57 EDT
Trying to adjust the resolution of second monitor LG 23" LED. 

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 18 Malar Kannan 2012-10-16 01:39:11 EDT
display server hung and restarted with ctrl+alt+backspace

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 Adam Jackson 2012-10-18 17:47:25 EDT
Please update to at least xorg-x11-server-1.12.3-2.fc17 and reopen if this is still reproduceable.
Comment 20 Malar Kannan 2012-10-19 15:38:44 EDT
i've commented on this bug and both of them appears to have the same *bugfeatures*

https://bugzilla.redhat.com/show_bug.cgi?id=857178
Comment 21 Andrey V. Henneberg 2012-10-20 04:53:09 EDT
I switched to doublehead mode using the following command:
xrandr --output VGA1 --mode 1360x768 --pos 1024x0 --output LVDS1 --mode 1024x600 --pos 0x0


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 22 Patrick Bregman 2012-10-24 02:40:27 EDT
I tried to start GNOME. It keeps failing and saying "Oh no! Something has gone wrong.". Behind the scenes everything seems to work just fine though.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 James Lee 2012-10-30 18:15:23 EDT
it just crashed all of sudden

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 24 Gustavo Olivares 2012-11-05 15:55:44 EST
I finished an update and then restarted.
After restart, I got a message that Xorg had crashed


Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 25 Malar Kannan 2012-11-05 22:33:33 EST
force shutdown?

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 26 Andrey V. Henneberg 2012-11-08 21:16:12 EST
I switched to singlehead mode using xrandr.

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 27 Corey Vollmer 2012-12-11 22:27:47 EST
Happend at startup.

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 28 Olivier 2012-12-12 15:34:54 EST
changed desktops configuration with ARandR

Package: xorg-x11-server-Xorg-1.12.4-1.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 29 StephTech 2013-01-12 22:42:29 EST
this keeps showing up multiple times a day

Package: xorg-x11-server-Xorg-1.12.4-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 30 StephTech 2013-01-12 22:49:12 EST
this keeps showing up multiple times a day, along with /user/bin/Xorg Xorg server crashed
I am not very well versed in Linux, and I have no idea what this is, but there are at least 50 of them listed - 

If you need me to send all that appear, I can do that.

I will send again to see if I get an "already reported" message...


Package: xorg-x11-server-Xorg-1.12.4-2.fc17
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 31 StephTech 2013-01-13 00:03:27 EST
just to try to further explain my last comment...

There are dozens of entries in the "not reported" section of ABRT. By selecting several of these entries, the only difference I can see is in the very end of the Directory address, so I would assume these are individual entries.

As I said before, I do not know Linux (although I love using it!). I have a screenshot of the ABRT screens to try to show what I mean, but I do not know how to attach it here...

I could not report another instance of this, I am now getting the message:

--- Running report_Bugzilla ---
Essential element 'component' is missing, can't continue
(exited with 1)
Comment 32 Peter Hutterer 2013-01-30 00:43:16 EST
I need the output of xinput list --long please.
Comment 33 Peter Hutterer 2013-01-30 00:43:50 EST
*** Bug 867410 has been marked as a duplicate of this bug. ***
Comment 34 Fabien de Saint pern 2013-01-30 10:24:51 EST
Created attachment 690413 [details]
xinput list --long

xinput list --long in attachment
Comment 35 Peter Hutterer 2013-01-30 23:44:24 EST
ok, I can see the device (last of the three nano transceivers) and why it would trigger the warning. However, I don't know yet why it's set up with a single axis and is missing x/y. Pls run evemu-describe against the device node (/dev/input/event9 in the log from bug 867410#c2, but this may have changed since).
Comment 36 Peter Hutterer 2013-01-30 23:46:19 EST
ok, I can see the device (last of the three nano transceivers) and why it would trigger the warning. However, I don't know yet why it's set up with a single axis and is missing x/y. Pls run evemu-describe against the device node (/dev/input/event9 in the log from bug 867410#c2, but this may have changed since).
Comment 37 Fabien de Saint pern 2013-02-01 08:48:30 EST
Created attachment 691588 [details]
evemu-describe /dev/input/event9 - Microsoft Microsoft® Nano Transceiver v2.0
Comment 38 Fedora Update System 2013-02-04 00:53:12 EST
xorg-x11-drv-evdev-2.7.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-evdev-2.7.3-5.fc17
Comment 39 Fedora Update System 2013-02-04 22:05:34 EST
Package xorg-x11-drv-evdev-2.7.3-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-evdev-2.7.3-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1926/xorg-x11-drv-evdev-2.7.3-5.fc17
then log in and leave karma (feedback).
Comment 40 Fabien de Saint pern 2013-02-06 04:37:57 EST
yum update --enablerepo=updates-testing xorg-x11-drv-evdev-2.7.3-5.fc17

No Match for argument: xorg-x11-drv-evdev-2.7.3-5.fc1
No package xorg-x11-drv-evdev-2.7.3-5.fc1 available.
No Packages marked for Update

Maybe xorg-x11-server-Xorg ?
Comment 41 Peter Hutterer 2013-02-07 00:19:44 EST
looks like you entered fc1, not fc17
Comment 42 Fedora Update System 2013-02-22 19:51:13 EST
xorg-x11-drv-evdev-2.7.3-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.