Bug 867410 - [abrt] xorg-x11-server-Xorg-1.12.3-2.fc17: Xorg server crashed
[abrt] xorg-x11-server-Xorg-1.12.3-2.fc17: Xorg server crashed
Status: CLOSED DUPLICATE of bug 847935
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
abrt_hash:9235415553f4818f8af3858124a...
:
: 863712 868396 869923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 09:08 EDT by Fabien de Saint pern
Modified: 2013-06-07 19:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 00:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: usr_share_xorg_conf_d.tar.gz (1.56 KB, text/plain)
2012-10-17 09:08 EDT, Fabien de Saint pern
no flags Details
File: Xorg.0.log (440.08 KB, text/plain)
2012-10-17 09:09 EDT, Fabien de Saint pern
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (370 bytes, text/plain)
2012-10-17 09:09 EDT, Fabien de Saint pern
no flags Details

  None (edit)
Description Fabien de Saint pern 2012-10-17 09:08:56 EDT
Description of problem:
Switch screen double / single head

Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.3-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
kernel:         3.6.1-1.fc17.x86_64

backtrace:
:0: /usr/bin/X (xorg_backtrace+0x36) [0x4652d6]
:1: /usr/bin/X (0x400000+0x4844c) [0x44844c]
:2: /usr/bin/X (0x400000+0x48c0d) [0x448c0d]
:3: /usr/bin/X (GetPointerEvents+0xe3) [0x44a003]
:4: /usr/bin/X (0x400000+0x15b0b6) [0x55b0b6]
:5: /usr/bin/X (miPointerWarpCursor+0xdb) [0x55b4eb]
:6: /usr/bin/X (0x400000+0x7cdf1) [0x47cdf1]
:7: /usr/bin/X (0x400000+0x15ba01) [0x55ba01]
:8: /usr/bin/X (0x400000+0xfe61f) [0x4fe61f]
:9: /usr/bin/X (0x400000+0x3b9b9) [0x43b9b9]
:10: /usr/bin/X (0x400000+0x4392d) [0x44392d]
:11: /usr/bin/X (0x400000+0x445f5) [0x4445f5]
:12: /usr/bin/X (0x400000+0x43d1d) [0x443d1d]
:13: /usr/bin/X (ProcAllowEvents+0xf6) [0x443ec6]
:14: /usr/bin/X (0x400000+0x3447a) [0x43447a]
:15: /usr/bin/X (0x400000+0x23485) [0x423485]
:16: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x35c1221735]
:17: /usr/bin/X (0x400000+0x2375d) [0x42375d]
Comment 1 Fabien de Saint pern 2012-10-17 09:08:59 EDT
Created attachment 628793 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 2 Fabien de Saint pern 2012-10-17 09:09:02 EDT
Created attachment 628794 [details]
File: Xorg.0.log
Comment 3 Fabien de Saint pern 2012-10-17 09:09:04 EDT
Created attachment 628795 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 4 Fabien de Saint pern 2012-10-22 04:23:20 EDT
Don't know...

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Adam Jackson 2012-11-29 17:11:53 EST
*** Bug 868396 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2012-11-29 17:11:56 EST
*** Bug 869923 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2012-11-29 17:12:50 EST
This is just tripping the BUG_ON() at the top of scale_to_desktop()
Comment 8 Adam Jackson 2012-11-30 11:28:23 EST
*** Bug 863712 has been marked as a duplicate of this bug. ***
Comment 9 stanley 2013-01-12 03:04:39 EST
xorg server relates to nivida 

Package: xorg-x11-server-Xorg-1.12.4-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Fedora Update System 2013-01-23 17:17:57 EST
xorg-x11-server-1.12.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.4-3.fc17
Comment 11 Fedora Update System 2013-01-24 17:29:40 EST
Package xorg-x11-server-1.12.4-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.12.4-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1410/xorg-x11-server-1.12.4-3.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-01-29 03:06:32 EST
xorg-x11-server-1.12.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.4-4.fc17
Comment 13 Peter Hutterer 2013-01-30 00:26:18 EST
can you submit the output of xinput list --long please, thanks.
Comment 14 Peter Hutterer 2013-01-30 00:43:50 EST
Looks like this is a dupe of bug 847935. Please submit the xinput output there.

*** This bug has been marked as a duplicate of bug 847935 ***
Comment 15 Fedora Update System 2013-02-14 16:38:30 EST
xorg-x11-server-1.12.4-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.4-6.fc17
Comment 16 Fedora Update System 2013-04-17 01:24:55 EDT
xorg-x11-server-1.12.4-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.4-7.fc17
Comment 17 Fedora Update System 2013-06-07 19:47:37 EDT
xorg-x11-server-1.12.4-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.