Bug 848074 - [Storage] Attaching illegal disks to VM must be prohibited.
[Storage] Attaching illegal disks to VM must be prohibited.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Maor
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 10:11 EDT by Leonid Natapov
Modified: 2016-02-10 15:26 EST (History)
11 users (show)

See Also:
Fixed In Version: SI15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 851201 (view as bug list)
Environment:
Last Closed: 2012-12-04 15:03:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2012-08-14 10:11:13 EDT
[Storage] Attaching illegal disks to VM must be prohibited.

IF for some reason disk that was attached to VM wasn't removed while VM deletion,we mark this disk as "illegal".
Now,we can attach illegal disk to another VM. This must be prohibited. Illegak disks can not be attached to VMs.
Comment 2 Maor 2012-08-15 10:27:05 EDT
post to upstream at http://gerrit.ovirt.org/#/c/7205/
Comment 3 Maor 2012-08-16 09:25:55 EDT
Merged upstream at 7130a5c782aa2810cf92978e410443bf05a94f77
Comment 5 Leonid Natapov 2012-08-22 10:24:58 EDT
How to reproduce:

1.Create VM with 10 disks.
2.Remove this VM and at the same time do restart to vdsmd on the host.

Because of restarting vdsmd some of vm's disks won't be removed and will be marked as illegal disks in the Disks tab.

After that try to attach disk to another VM. Make sure that no illegal disks appear in the "add disk" dialog.
Comment 6 Maor 2012-08-23 09:27:52 EDT
The fix adds validation when attaching illegal disks.(In reply to comment #5)
> How to reproduce:
> 
> 1.Create VM with 10 disks.
> 2.Remove this VM and at the same time do restart to vdsmd on the host.
> 
> Because of restarting vdsmd some of vm's disks won't be removed and will be
> marked as illegal disks in the Disks tab.
> 
> After that try to attach disk to another VM. Make sure that no illegal disks
> appear in the "add disk" dialog.
The fix adds validation when attaching illegal disks.
Comment 7 Dafna Ron 2012-08-23 09:33:56 EDT
verified on si15 that we cannot attach the disks with illegal state with CanDoAction. 
cloning this bug to webadmin to filter these disks from the results of add disk.

Note You need to log in before you can comment on or make changes to this bug.