Bug 851201 - webadmin: illegal disks can be chosen in add disk dialogue
webadmin: illegal disks can be chosen in add disk dialogue
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 09:37 EDT by Dafna Ron
Modified: 2016-02-10 15:23 EST (History)
16 users (show)

See Also:
Fixed In Version: SI17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 848074
Environment:
Last Closed: 2012-12-04 15:07:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-08-23 09:37:17 EDT
we are currently blocking attach of disks in illegal state which is good for api users. but for webadmin users it would be better if we filter the illegal disks from the add disk dialogue when trying to attach. 
=============================================================================




+++ This bug was initially created as a clone of Bug #848074 +++

[Storage] Attaching illegal disks to VM must be prohibited.

IF for some reason disk that was attached to VM wasn't removed while VM deletion,we mark this disk as "illegal".
Now,we can attach illegal disk to another VM. This must be prohibited. Illegak disks can not be attached to VMs.

--- Additional comment from pm-rhel@redhat.com on 2012-08-15 03:53:06 EDT ---

This request has been proposed as an exception, but a release flag has
not been requested. Please set a release flag to ? to ensure we may
track this bug against the appropriate upcoming release, and reset the
exception flag to ?.

--- Additional comment from mlipchuk@redhat.com on 2012-08-15 10:27:05 EDT ---

post to upstream at http://gerrit.ovirt.org/#/c/7205/

--- Additional comment from mlipchuk@redhat.com on 2012-08-16 09:25:55 EDT ---

Merged upstream at 7130a5c782aa2810cf92978e410443bf05a94f77

--- Additional comment from amureini@redhat.com on 2012-08-19 09:27:34 EDT ---

merged downstream, https://gerrit.eng.lab.tlv.redhat.com/#/c/1345/

--- Additional comment from lnatapov@redhat.com on 2012-08-22 10:24:58 EDT ---

How to reproduce:

1.Create VM with 10 disks.
2.Remove this VM and at the same time do restart to vdsmd on the host.

Because of restarting vdsmd some of vm's disks won't be removed and will be marked as illegal disks in the Disks tab.

After that try to attach disk to another VM. Make sure that no illegal disks appear in the "add disk" dialog.

--- Additional comment from mlipchuk@redhat.com on 2012-08-23 09:27:52 EDT ---

The fix adds validation when attaching illegal disks.(In reply to comment #5)
> How to reproduce:
> 
> 1.Create VM with 10 disks.
> 2.Remove this VM and at the same time do restart to vdsmd on the host.
> 
> Because of restarting vdsmd some of vm's disks won't be removed and will be
> marked as illegal disks in the Disks tab.
> 
> After that try to attach disk to another VM. Make sure that no illegal disks
> appear in the "add disk" dialog.
The fix adds validation when attaching illegal disks.

--- Additional comment from dron@redhat.com on 2012-08-23 09:33:56 EDT ---

verified on si15 that we cannot attach the disks with illegal state with CanDoAction. 
cloning this bug to webadmin to filter these disks from the results of add disk.
Comment 1 Dafna Ron 2012-08-23 09:55:29 EDT
this bug is opened on si15
Comment 2 Ayal Baron 2012-08-23 18:17:23 EDT
Daniel, what would be required for this?
Comment 3 Ayal Baron 2012-08-26 06:07:22 EDT
After discussing with Daniel this should be pretty simple.
Daniel, please make sure there aren't additional places where illegal disks should be filtered out.
Comment 6 Ayal Baron 2012-08-27 21:28:34 EDT
Dafna, screenshot? logs?
Comment 7 Daniel Erez 2012-08-29 13:13:23 EDT
patch sent upstream:
http://gerrit.ovirt.org/#/c/7589/
Comment 10 Allon Mureinik 2012-09-03 16:05:08 EDT
Merged change id Ia302712c7c49f0818bbb44e46339b8e5867ce69c
Comment 11 Dafna Ron 2012-09-06 04:27:15 EDT
verified on si17

Note You need to log in before you can comment on or make changes to this bug.