Bug 848378 - automake-1.13.1 is available
automake-1.13.1 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: automake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 09:07 EDT by Upstream Release Monitoring
Modified: 2013-01-12 07:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-12 07:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-08-15 09:07:06 EDT
Latest upstream release: 1.12.3
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Account closed by user 2012-08-28 10:59:19 EDT
New in 1.12.3:

* WARNING: Future backward-incompatibilities!

  - Future versions of Automake will likely drop support for the
    long-deprecated 'configure.in' name for the Autoconf input file.
    You are advised to use the recommended name 'configure.ac' instead.

  - The long-obsolete (since automake 1.10) AM_PROG_MKDIR m4 macro will
    be removed in Automake 1.13.  The $(mkdir_p) make variable and the
    @mkdir_p@ substitution will still remain available (as aliases of
    $(MKDIR_P)) for the moment, for better backward compatibility.

  - Autoconf 2.65 or later will be required by the next major Automake
    version (1.13).  Until now, Automake has required Autoconf version
    2.62 or later.

  - Starting from the next major Automake version (1.13), the rules
    to build pdf, ps and dvi output from Texinfo input will use the
    '--build-dir' option by default.  Since such an option was only
    introduced in Texinfo 4.9, this means that Makefiles generated by
    future Automake versions will require at least that version of
    Texinfo.

  - Starting from the next major Automake version (1.13), the parallel
    testsuite harness (previously only enabled by the 'parallel-tests'
    option) will become the default one; the older serial testsuite
    harness will still be available through the use of the 'serial-tests'
    option.

  - The following long-obsolete m4 macros will be removed in the
    next major Automake version (1.13):

      AM_PROG_CC_STDC:    superseded by AC_PROG_CC since October 2002
      fp_PROG_CC_STDC:    broken alias for AM_PROG_CC_STDC
      fp_WITH_DMALLOC:    old alias for AM_WITH_DMALLOC
      AM_CONFIG_HEADER:   superseded by AC_CONFIG_HEADERS since July 2002
      ud_PATH_LISPDIR:    old alias for AM_PATH_LISPDIR
      jm_MAINTAINER_MODE: old alias for AM_MAINTAINER_MODE
      ud_GNU_GETTEXT:     old alias for AM_GNU_GETTEXT
      gm_PROG_LIBTOOL:    old alias for AC_PROG_LIBTOOL
      fp_C_PROTOTYPES:    old alias for AM_C_PROTOTYPES (which was part
                          of the now-removed automatic de-ANSI-fication
                          support of Automake)

  - All the "old alias" macros in 'm4/obsolete.m4' will be removed in
    the next major Automake version (1.13).

  - Support for the two- and three-arguments invocation forms of the
    AM_INIT_AUTOMAKE macro is deprecated, and will be removed in the
    next major Automake version (1.13).

  - The '--acdir' option of aclocal is deprecated, and will probably
    be removed in the next major Automake release (1.13).  You should
    use the options '--automake-acdir' and '--system-acdir' instead
    (which have been introduced in Automake 1.11.2).

  - The exact order in which the directories in the aclocal macro
    search path are looked up is probably going to be changed in the
    next Automake release (1.13).

  - The 'missing' script will not try anymore to update the timestamp
    of out-of-date files that require a maintainer-specific tool to be
    remade, in case the user lacks such a tool (or has a too-old version
    of it).  In fact, starting from Automake 1.13, all it'll do will be
    giving more useful warnings than a bare "command not found" from a
    make recipe would.

* Miscellaneous changes:

  - The '.m4' files provided by Automake does not define serial numbers
    anymore.  This should cause no difference in the behaviour of aclocal
    though.

  - Some testsuite weaknesses and spurious failures have been fixed.

  - There is initial support for automatic dependency tracking with the
    Portland Group C/C++ compilers, thanks to the new new depmode 'pgcc'.

Bugs fixed in 1.12.3:

* Long-standing bugs:

  - Instead of renaming only self-references of files (typically for
    #lines), ylwrap now also renames references to the other generated
    files.  This fixes support for GLR and C++ parsers from Bison (PR
    automake/491 and automake bug#7648): 'parser.c' now properly
    #includes 'parser.h' instead of 'y.tab.h'.

  - Generated files unknown to ylwrap are now preserved.  This fixes
    C++ support for Bison (automake bug#7648): location.hh and the
    like are no longer discarded.
Comment 2 Upstream Release Monitoring 2012-09-19 03:01:43 EDT
Latest upstream release: 1.12.4
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Account closed by user 2012-09-19 08:14:52 EDT
New in 1.12.4:

* WARNING: Future backward-incompatibilities!

  - Future versions of Automake will likely drop support for the
    long-deprecated 'configure.in' name for the Autoconf input file.
    You are advised to use the recommended name 'configure.ac' instead.

  - Support for the "Cygnus-style" trees (as enabled by the 'cygnus'
    option) will be removed in the next major Automake release (1.13).

  - The long-obsolete (since automake 1.10) AM_PROG_MKDIR m4 macro will
    be removed in Automake 1.13.  The $(mkdir_p) make variable and the
    @mkdir_p@ substitution will still remain available (as aliases of
    $(MKDIR_P)) for the moment, for better backward compatibility.

  - Autoconf 2.65 or later will be required by the next major Automake
    version (1.13).  Until now, Automake has required Autoconf version
    2.62 or later.

  - Starting from the next major Automake version (1.13), the rules
    to build pdf, ps and dvi output from Texinfo input will use the
    '--build-dir' option by default.  Since such an option was only
    introduced in Texinfo 4.9, this means that Makefiles generated by
    future Automake versions will require at least that version of
    Texinfo.

  - Starting from the next major Automake version (1.13), the parallel
    testsuite harness (previously only enabled by the 'parallel-tests'
    option) will become the default one; the older serial testsuite
    harness will still be available through the use of the 'serial-tests'
    option.

  - The following long-obsolete m4 macros will be removed in the
    next major Automake version (1.13):

      AM_PROG_CC_STDC:    superseded by AC_PROG_CC since October 2002
      fp_PROG_CC_STDC:    broken alias for AM_PROG_CC_STDC
      fp_WITH_DMALLOC:    old alias for AM_WITH_DMALLOC
      AM_CONFIG_HEADER:   superseded by AC_CONFIG_HEADERS since July 2002
      ud_PATH_LISPDIR:    old alias for AM_PATH_LISPDIR
      jm_MAINTAINER_MODE: old alias for AM_MAINTAINER_MODE
      ud_GNU_GETTEXT:     old alias for AM_GNU_GETTEXT
      gm_PROG_LIBTOOL:    old alias for AC_PROG_LIBTOOL
      fp_C_PROTOTYPES:    old alias for AM_C_PROTOTYPES (which was part
                          of the now-removed automatic de-ANSI-fication
                          support of Automake)

  - All the "old alias" macros in 'm4/obsolete.m4' will be removed in
    the next major Automake version (1.13).

  - The '--acdir' option of aclocal is deprecated, and will probably
    be removed in the next major Automake release (1.13).  You should
    use the options '--automake-acdir' and '--system-acdir' instead
    (which have been introduced in Automake 1.11.2).

  - The 'missing' script will not try anymore to update the timestamp
    of out-of-date files that require a maintainer-specific tool to be
    remade, in case the user lacks such a tool (or has a too-old version
    of it).  In fact, starting from Automake 1.13, all it'll do will be
    giving more useful warnings than a bare "command not found" from a
    make recipe would.

* Warnings and deprecations:

  - Warnings in the 'obsolete' category are enabled by default both in
    automake and aclocal.

* Miscellaneous changes:

  - Some testsuite weaknesses and spurious failures have been fixed.
Comment 4 Upstream Release Monitoring 2012-11-18 04:33:05 EST
Latest upstream release: 1.12.5
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 5 Upstream Release Monitoring 2012-12-16 16:03:24 EST
Latest upstream release: 1.12.6
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 6 Upstream Release Monitoring 2012-12-29 05:59:10 EST
Latest upstream release: 1.13
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 7 Upstream Release Monitoring 2013-01-01 10:43:32 EST
Latest upstream release: 1.13.1
Current version in Fedora Rawhide: 1.12.2
URL: http://ftp.gnu.org/gnu/automake/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 8 Pavel Raiskup 2013-01-10 03:51:23 EST
Here is some upstream info about newer releses:

automake-1.13:

    http://lists.gnu.org/archive/html/automake/2012-12/msg00038.html

automake-1.13.1:

    http://lists.gnu.org/archive/html/automake/2013-01/msg00000.html

Pavel
Comment 9 Pavel Raiskup 2013-01-12 07:10:38 EST
Updated version 1.3.1 is in Rawhide.  ~~> CLOSED

Note You need to log in before you can comment on or make changes to this bug.