Bug 848543 - brick directory is automatically recreated, e.g. when disk not mounted
brick directory is automatically recreated, e.g. when disk not mounted
Status: CLOSED DUPLICATE of bug 948729
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.2.5
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 16:52 EDT by Jochen Klein
Modified: 2014-12-14 14:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:30:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Klein 2012-08-15 16:52:32 EDT
Description of problem:
brick directory is automatically recreated if it does not exist, e.g. when a dead disk could not be mounted

Version-Release number of selected component (if applicable):
3.2.5

How reproducible:
always

Steps to Reproduce:
1. create a volume with several bricks, say /mnt/disk{1,2,3}/brick
2. remove one mount, say /mnt/disk1/brick, but leave it in the volume
3. restart gluster (not sure if needed)
  
Actual results:
the brick directory /mnt/disk1/brick gets recreated and filled, now not on the intendend disk but on the filesystem where the mount point is (typically root partition), no warning in the brick log, only when no space left to write

Expected results:
failure to read/write from/to this brick, don't write to this brick, error message at least in the brick log

Additional info:
Comment 1 Jochen Klein 2012-08-15 18:17:53 EDT
(In reply to comment #0)
> Description of problem:
> brick directory is automatically recreated if it does not exist, e.g. when a
> dead disk could not be mounted
> 
> Version-Release number of selected component (if applicable):
> 3.2.5
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. create a volume with several bricks, say /mnt/disk{1,2,3}/brick
> 2. remove one mount, say /mnt/disk1/brick, but leave it in the volume
> 3. restart gluster (not sure if needed)
>   
> Actual results:
> the brick directory /mnt/disk1/brick gets recreated and filled, now not on
> the intendend disk but on the filesystem where the mount point is (typically
> root partition), no warning in the brick log, only when no space left to
> write
> 
> Expected results:
> failure to read/write from/to this brick, don't write to this brick, error
> message at least in the brick log
> 
> Additional info:

- the brick dirs are recreated when the volume is stopped and started again
- the problem does not occur with in 3.3
Comment 2 Shawn Heisey 2012-10-12 11:27:18 EDT
I recently filed a couple of related bugs:

Bug 864611, a similar problem which does affect 3.3.
Bug 864638, which if implemented would prevent many problems like this.
Comment 4 Vijay Bellur 2013-03-28 06:12:56 EDT
REVIEW: http://review.gluster.org/4740 (glusterd: changes in 'volume create' behaviour) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Niels de Vos 2014-11-27 09:54:53 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.
Comment 6 Shawn Heisey 2014-11-27 11:49:16 EST
I don't have a newer version to try it on, but as a developer of the software, you must have testbeds where you can verify behavior.  With one of those, it would be almost trivial for you to try it and see if the behavior is still the same.
Comment 7 Niels de Vos 2014-12-14 14:30:58 EST
Seems to have been fixed in 3.4.

*** This bug has been marked as a duplicate of bug 948729 ***

Note You need to log in before you can comment on or make changes to this bug.