Bug 848641 - Fedora 18 Alpha TC2 fails to boot from USB stick (written by livecd-iso-to-disk)
Fedora 18 Alpha TC2 fails to boot from USB stick (written by livecd-iso-to-disk)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On: 851295
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-16 01:49 EDT by Adam Williamson
Modified: 2013-07-04 09:03 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 16:56:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log of the boot failure, from journalctl with rd.debug (251.71 KB, text/plain)
2012-08-16 01:49 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-08-16 01:49:22 EDT
Created attachment 604793 [details]
log of the boot failure, from journalctl with rd.debug

I wrote F18 Alpha TC2 boot.iso to USB with livecd-iso-to-disk. It fails to boot. dracut seems to be trying to mount /dev/sr0 even though I'm booting from USB. Attaching the full log (from journalctl) after booting with rd.debug. This potentially blocks Alpha:

"The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"

Though to be sure, we'd have to test the other supported USB stick-writing methods.
Comment 1 Kamil Páral 2012-08-16 04:18:51 EDT
I don't know whether there is a USB-related problem, but the original DVD doesn't boot either - bug 848682.
Comment 2 Adam Williamson 2012-08-16 12:10:04 EDT
This is different from that. That's when it gets to the point of X init and fails - hangs, actually. This is an earlier failure, it never makes it out of dracut.
Comment 3 Adam Williamson 2012-08-16 15:03:14 EDT
Discussed at 2012-08-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-16/f18-alpha-blocker-review-3.2012-08-16-16.00.html . Agreed that we need to test all USB methods before we can declare a blocker situation (for Alpha, we only require that *any one* of the USB methods produces a bootable stick).
Comment 4 Kamil Páral 2012-08-20 09:45:23 EDT
I tried all three methods with DVD.iso - dd, livecd-iso-to-disk and liveusb-creator. The same problem for all of them, it complains that it can't mount /dev/sr0.
Comment 5 Adam Williamson 2012-08-20 19:25:04 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Based on Kamil's testing from comment #4, this is accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods".
Comment 6 Vratislav Podzimek 2012-08-22 04:52:30 EDT
Brian, should live* tools point dracut to the Live system, or is this a dracut bug?
Comment 7 Brian Lane 2012-08-22 10:42:40 EDT
dd should 'just work' so that would indicate a problem with anaconda-dracut. I think wwoods was looking into this.
Comment 8 Will Woods 2012-08-22 17:32:23 EDT
Since there's no 'inst.repo=' or 'inst.stage2=' or 'root=' arguments, anaconda-dracut does what it's supposed to do and tries to find the DVD. Which, obviously, isn't there.

(No, we can't probe *every* disk on the system. We *can* automatically find CD/DVD media, though, which is why that works.)

In the past we used the 'root=' argument on the install media (which was then carried over when using `dd`). But using 'root=' instead of 'inst.{repo,stage2}' doesn't enable the Special Installer Magic (automatically finding kickstarts, updates.img, etc.) so that was removed in favor of the CD autoprobe stuff.

I think livecd-iso-to-disk used to update the 'root=' argument to point to the correct device/label, except since there's no argument, nothing gets updated.

livecd-iso-to-disk *could* add the root/inst.stage2/inst.repo argument, but that wouldn't fix devices made using `dd`.

For both methods to work, we need *some* boot argument that tells initramfs where to find the installer images. l-i-c-d will need to update that when it writes to an existing partition. And we'll also need to ensure that those arguments enable the Special Installer Magic.
Comment 9 Adam Williamson 2012-08-22 20:05:22 EDT
It's probably not terribly important, but actually, it only 'just worked' for dd in F17 (and possibly F16, I don't entirely recall, but certainly only one or two recent releases). For a long time it didn't actually 'just work' - you had to manually add or edit the root= parameter if you dd'ed the DVD image to a USB stick, or it'd just act as a network install image. We did something specific to make it work 'properly', quite recently.
Comment 10 Piruthiviraj Natarajan 2012-08-31 13:05:02 EDT
What kind of root paramater would be this time, any idea?
Comment 11 Fedora Update System 2012-09-01 01:12:17 EDT
lorax-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.17-1.fc18
Comment 12 Fedora Update System 2012-09-01 12:56:51 EDT
Package lorax-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13109/lorax-18.17-1.fc18
then log in and leave karma (feedback).
Comment 13 Jóhann B. Guðmundsson 2012-09-01 14:02:14 EDT
I think this one is still present with latest TC (5) as in running "dd if=Fedora-18-Alpha-TC5-x86_64-DVD.iso of=/dev/sdb bs=8M" dracut not finding /dev/root and dropping users to dracut shell.

Without this support Fedora cant be installed on hardware that does not have cd/dvd drives which is getting more common these days ( like my own personal laptop )

Dracut-initqueue[323]: Warning could not boot 
Dracut-initqueue[323]: Warning /dev/root does not exist
Comment 14 Jóhann B. Guðmundsson 2012-09-01 14:55:55 EDT
Same thing with

livecd-iso-to-disk --format --msdos --reset-mbr Fedora-18-Alpha-TC5-x86_64-DVD.iso /dev/sdb

Either one of those ( DD or livecd ) needs to work so this can be taken off the blocker bug list..
Comment 15 Kamil Páral 2012-09-03 05:52:14 EDT
How can we check whether the new lorax was used to build Alpha TC5?
Comment 16 Kamil Páral 2012-09-04 10:51:44 EDT
<dgilmore> kparal: there is no logs publicly available
<dgilmore> kparal: lorax was lorax-18.16-1.fc18

Therefore it shouldn't have been fixed in TC5 and we have to wait for TC6.
Comment 17 Fedora Update System 2012-09-05 21:48:53 EDT
lorax-18.17-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Adam Williamson 2012-09-06 16:56:33 EDT
TC6 x64 netinst, written with livecd-iso-to-disk, boots fine to stage2. Closing.

Note You need to log in before you can comment on or make changes to this bug.