Bug 848682 - anaconda boots into a black screen
anaconda boots into a black screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 848675 848683 848780 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-16 04:17 EDT by Kamil Páral
Modified: 2012-08-21 07:39 EDT (History)
18 users (show)

See Also:
Fixed In Version: lorax-18.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 07:39:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (1.63 KB, text/plain)
2012-08-16 05:12 EDT, Kamil Páral
no flags Details
program.log (16.26 KB, text/plain)
2012-08-16 05:12 EDT, Kamil Páral
no flags Details
storage.log (34.32 KB, text/plain)
2012-08-16 05:12 EDT, Kamil Páral
no flags Details
syslog (72.09 KB, text/plain)
2012-08-16 05:12 EDT, Kamil Páral
no flags Details
X.log (48.71 KB, text/plain)
2012-08-16 05:13 EDT, Kamil Páral
no flags Details
bare metal - anaconda.log (1.03 KB, text/plain)
2012-08-16 05:41 EDT, Kamil Páral
no flags Details
bare metal - program.log (1.02 KB, text/plain)
2012-08-16 05:41 EDT, Kamil Páral
no flags Details
bare metal - syslog (131.16 KB, text/plain)
2012-08-16 05:41 EDT, Kamil Páral
no flags Details
bare metal - X.log (30.26 KB, text/plain)
2012-08-16 05:41 EDT, Kamil Páral
no flags Details
bare metal - main VT (676.40 KB, image/jpeg)
2012-08-16 05:47 EDT, Kamil Páral
no flags Details
anaconda log (1.03 KB, text/x-log)
2012-08-16 11:17 EDT, Timothy Davis
no flags Details
X log (122.66 KB, text/x-log)
2012-08-16 11:18 EDT, Timothy Davis
no flags Details

  None (edit)
Description Kamil Páral 2012-08-16 04:17:23 EDT
Description of problem:
The boot continues up to the point where "Starting Anaconda" message is written to the screen. Then there is just black screen and I can't do anything expect hard reboot.

I tried to run it with console=ttyS0 to get some logs, but then anaconda booted into a text mode successfully (it crashed some time later, but that's not relevant for this bug). So I'm not sure how to get logs from a normal (graphical mode) boot.

Version-Release number of selected component (if applicable):
F18 Alpha TC2 DVD (both archs)
KVM

How reproducible:
always

Steps to Reproduce:
1. boot
Comment 1 Piruthiviraj Natarajan 2012-08-16 04:35:04 EDT
Dracut-initqueue error for me in X86_64 netinstall.iso, almost similar error as in TC1.
Comment 2 Vadim Rutkovsky 2012-08-16 04:52:33 EDT
It seems that dbus-daemon failed to start:
# systemctl status dbus.service -o cat
dbus.service - D-Bus System Message Bus
	  Loaded: loaded (/usr/lib/systemd/system/dbus.service; static)
	  Active: active (running) since Thu, 16 Aug 2012 08:42:08 +0000; 10min ago
	Main PID: 480 (dbus-daemon)
	  CGroup: name=systemd:/system/dbus.service
		  ├ 480 /bin/dbus-daemon --system --address=systemd: --nof...
		  └ 510 /usr/sbin/modem-manager

modem-manager[510]: <info>  Loaded plugin 'Generic'
modem-manager[510]: <info>  Successfully loaded 20 plugins
[system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
dbus[480]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
dbus[480]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
[system] Successfully activated service 'org.freedesktop.nm_dispatcher'
grep: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory
grep: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory
Failed to issue method call: Unit chronyd.service is not loaded.
grep: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory
Comment 3 Kamil Páral 2012-08-16 05:01:58 EDT
Vadim: This is a different bug, please file a separate one, thanks.
Comment 4 Kamil Páral 2012-08-16 05:10:16 EDT
I found out that supplying 'console=ttyS0 graphical' allows me to intercept console output while forcing graphical mode instead of textual one.

The text displayed is:
> Starting installer, one moment...
> anaconda 18.5 for Fedora 18-Alpha-TC2 (pre-release) started.
> 08:58:38 X startup failed, falling back to text mode

So clearly this is a problem of X starting up. Unfortunately the screen stays black even if you try to switch TTYs, so a 'rescue text mode' doesn't help at all.

Attaching logs.
Comment 5 Kamil Páral 2012-08-16 05:12:46 EDT
Created attachment 604835 [details]
anaconda.log
Comment 6 Kamil Páral 2012-08-16 05:12:50 EDT
Created attachment 604836 [details]
program.log
Comment 7 Kamil Páral 2012-08-16 05:12:53 EDT
Created attachment 604837 [details]
storage.log
Comment 8 Kamil Páral 2012-08-16 05:12:56 EDT
Created attachment 604838 [details]
syslog
Comment 9 Kamil Páral 2012-08-16 05:13:00 EDT
Created attachment 604839 [details]
X.log
Comment 10 Kamil Páral 2012-08-16 05:20:55 EDT
Hmm, maybe comment #2 is related. It seems some important libraries are missing. Even grep can't be used:

# grep
grep: er: No such file or directorybraries: libpcre.so.1: cannot open shared object file

That can be also the reason why Xorg fails to start.
Comment 11 Kamil Páral 2012-08-16 05:40:15 EDT
The previous was run in a VM with "console=ttyS0 graphical".

Now I have run it on a bare metal without any extra options, and it behaves a bit differently. Attaching logs.
Comment 12 Kamil Páral 2012-08-16 05:41:11 EDT
Created attachment 604853 [details]
bare metal - anaconda.log
Comment 13 Kamil Páral 2012-08-16 05:41:16 EDT
Created attachment 604854 [details]
bare metal - program.log
Comment 14 Kamil Páral 2012-08-16 05:41:23 EDT
Created attachment 604855 [details]
bare metal - syslog
Comment 15 Kamil Páral 2012-08-16 05:41:28 EDT
Created attachment 604856 [details]
bare metal - X.log
Comment 16 Andre Robatino 2012-08-16 05:46:07 EDT
Same in a VirtualBox 4.1.18 VM, both DVD and netinst, both i386 and x86_64.
Comment 17 Kamil Páral 2012-08-16 05:47:25 EDT
Created attachment 604862 [details]
bare metal - main VT
Comment 18 Michele Baldessari 2012-08-16 05:48:29 EDT
Same here with i386 on an older iMac with an nVidia G73 (GeForce 7300 GT)
Comment 19 Joachim Backes 2012-08-16 08:03:33 EDT
*** Bug 848780 has been marked as a duplicate of this bug. ***
Comment 20 Vratislav Podzimek 2012-08-16 09:48:46 EDT
*** Bug 848675 has been marked as a duplicate of this bug. ***
Comment 21 Vratislav Podzimek 2012-08-16 09:49:39 EDT
*** Bug 848683 has been marked as a duplicate of this bug. ***
Comment 22 Vratislav Podzimek 2012-08-16 09:59:25 EDT
(In reply to comment #10)
> Hmm, maybe comment #2 is related. It seems some important libraries are
> missing. Even grep can't be used:
> 
> # grep
> grep: er: No such file or directorybraries: libpcre.so.1: cannot open shared
> object file
> 
> That can be also the reason why Xorg fails to start.
Martin, any place in lorax where this library may be removed? Bare metal case fails on missing libgtk3.
Comment 23 Timothy Davis 2012-08-16 11:17:27 EDT
Created attachment 604967 [details]
anaconda log
Comment 24 Timothy Davis 2012-08-16 11:18:07 EDT
Created attachment 604968 [details]
X log
Comment 25 Timothy Davis 2012-08-16 11:19:46 EDT
I think it's related to the current bug 845745
X doesn't start with the latest kernels on certain ATI GPUs
Comment 26 Adam Williamson 2012-08-16 12:09:18 EDT
No, I don't think so. It appears that X startup fails on all systems, including virtual machines.

bcl believes https://admin.fedoraproject.org/updates/lorax-18.14-1.fc18 should fix this, or at any rate improve it.
Comment 27 Brian Lane 2012-08-16 12:18:38 EDT
We were removing some libs that Gtk is now depending on. lorax-18.14-1 will fix this.
Comment 28 Fedora Update System 2012-08-16 12:19:43 EDT
lorax-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.14-1.fc18
Comment 29 Fedora Update System 2012-08-16 12:52:15 EDT
Package lorax-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11979/lorax-18.14-1.fc18
then log in and leave karma (feedback).
Comment 30 Adam Williamson 2012-08-16 15:04:30 EDT
Discussed at 2012-08-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-16/f18-alpha-blocker-review-3.2012-08-16-16.00.html . Accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods".
Comment 31 Adam Williamson 2012-08-17 15:42:23 EDT
TC3 fixes this. *important* note if you're testing in a VM: you may still run into problems at X start, but it is no longer this bug, there are two other known bugs in the most common KVM video adapter/driver combos. See https://bugzilla.redhat.com/show_bug.cgi?id=848930 (cirrus bug) and https://bugzilla.redhat.com/show_bug.cgi?id=844463 (qxl bug).
Comment 32 Fedora Update System 2012-08-21 07:39:10 EDT
lorax-18.14-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.