This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 848704 - Globally uncaught exception when trying to add a second entry for 'Allow Override' directive in Apache resource->Directories
Globally uncaught exception when trying to add a second entry for 'Allow Over...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.1
Unspecified Unspecified
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
: 960656 (view as bug list)
Depends On: 859982
Blocks: 1012123
  Show dependency treegraph
 
Reported: 2012-08-16 05:02 EDT by Sunil Kondkar
Modified: 2014-01-02 15:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 859982 1012123 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error (16.98 KB, text/plain)
2012-08-16 05:03 EDT, Sunil Kondkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 363994 None None None Never

  None (edit)
Description Sunil Kondkar 2012-08-16 05:02:21 EDT
Description of problem:

When trying to add a second entry for 'Allow Override' directive in a directory apache resource (Ex: /var/www/error Directory), unchecking the 'Unset' checkbox for 'Param' field display globally uncaught exception in UI and message center.

Please find attached the details of error attached.

There are no errors in server or agent log.

Version-Release number of selected component (if applicable):

Build: Version: 3.1.1.ER2
Build Number: f546515:4eb3f2c
Database: PostgreSQL 8.3.8
Browser: Firefox 10.0.2
Java Version: jre1.7.0_05

How reproducible:

Always

Steps to Reproduce:

1. Login to JBoss ON.
2. Navigate to the apache httpd resource->Apache Virtual Hosts->Main->Directories->Any directory (Ex: /var/www/error Directory).
3. Navigate to 'Configuration->Current' tab of the directory.
4. Navigate to the 'Inventory' tab of the virtual host.
5. Click on 'Add' symbol in 'Allow Override' section.
6. Uncheck the 'Unset' checkbox for 'Param' field
7. Enter a value in 'Param' field (Ex: AuthConfig)
8  Click on OK button.
9. Again click on 'Add' symbol in 'Allow Override' section.
10. Uncheck the 'Unset' checkbox for 'Param' field.
11. UI in the background displays globally uncaught exception.
  
Actual results:

UI displays globally uncaught exception.

Expected results:

No error should be displayed

Additional info:

Observed the same error when following the same steps in Apache IfModule (Ex: Apache Resource->Main->Ifmodules->mod_include.c->Configuration->Allow Override section)
Comment 1 Sunil Kondkar 2012-08-16 05:03:48 EDT
Created attachment 604832 [details]
Error
Comment 2 Sunil Kondkar 2012-08-16 08:37:12 EDT
More Info: This is not a JRE7 related bug. I reproduced it on jdk1.6.0_18.
Comment 3 Lukas Krejci 2012-09-24 08:48:37 EDT
This is most probably an UI issue with editing new entries in the list of maps and is not directly associated with the Apache plugin.
Comment 4 Lukas Krejci 2012-09-25 09:23:41 EDT
Bug 859982 has a fix committed to master.
Comment 5 mark yarborough 2012-11-20 15:45:35 EST
Per triage with loleary, crouch, mfoley: Move to JBoss ON product, set target release JON 3.2, clear priority (will be subject to further triage in JON 3.2 timeframe).
Comment 6 Larry O'Leary 2012-11-21 19:23:42 EST
As per comment 4, this is already fixed upstream.
Comment 7 Thomas Segismont 2013-07-19 10:49:05 EDT
Fixed in master
Comment 8 Thomas Segismont 2013-07-19 10:51:48 EDT
*** Bug 960656 has been marked as a duplicate of this bug. ***
Comment 9 Larry O'Leary 2013-09-06 10:32:27 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 10 Sunil Kondkar 2013-09-20 07:53:12 EDT
Verified on JBoss ON Version: 3.2.0.ER1- Build Number: 54dd29c:464a643

Note You need to log in before you can comment on or make changes to this bug.