Bug 848892 - Cherokee systemd service never starts due to a timeout
Cherokee systemd service never starts due to a timeout
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cherokee (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 13:50 EDT by Jean-François Fortin Tam
Modified: 2012-12-05 21:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 21:48:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-François Fortin Tam 2012-08-16 13:50:37 EDT
SELinux is disabled.


[root@krom jeff]# service cherokee enable
Redirecting to /bin/systemctl enable  cherokee.service

[root@krom jeff]# service cherokee start
Redirecting to /bin/systemctl start  cherokee.service

(wait a minute or so)

Job failed. See system journal and 'systemctl status' for details.



[root@krom jeff]# service cherokee status
Redirecting to /bin/systemctl status  cherokee.service
cherokee.service - Cherokee Lightweight Web Server
	  Loaded: loaded (/usr/lib/systemd/system/cherokee.service; enabled)
	  Active: failed (Result: timeout) since Fri, 10 Aug 2012 16:12:10 -0400
	  CGroup: name=systemd:/system/cherokee.service



And yet, *during the minute where service cherokee start is running* (ie: before it supposedly spits a timeout error), cherokee is actually running fine (you can access the web server's pages and all that). It is only when systemd "gives up" that it kills the cherokee server and everything becomes inaccessible.
Comment 1 Paweł 2012-10-05 14:47:22 EDT
Solution https://bugzilla.redhat.com/show_bug.cgi?id=786748#c3
Comment 2 Jean-François Fortin Tam 2012-12-05 21:48:30 EST
Works for me now in Fedora 18.

Note You need to log in before you can comment on or make changes to this bug.