Bug 849075 - graphical installation doesn't ask for root password
graphical installation doesn't ask for root password
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 04:57 EDT by Jan Sedlák
Modified: 2012-08-20 03:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 09:49:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2012-08-17 04:57:14 EDT
Description of problem:
As it was reported in bug 848803, graphical installation doesn't even prompt for root password. After (base) GUI installation it boots into login prompt, but I was unable to set root password or at least create regular user before, so I cannot login.

How reproducible:
Always

Steps to Reproduce:
1. install F18 TC3 using GUI instalator
2. reboot
  
Actual results:
There was nowhere to set root password, so I cannot login.

Expected results:
Somewhere during instalation it should ask for root password.
Comment 1 Chris Lumens 2012-08-17 09:49:54 EDT
Right, so the graphical installer does not set up the root account now.  The intended flow is that when you create your user with firstboot, it is added to the sudoers group.  In the text mode install since there is no firstboot, there's a root password entry.  For minimal graphical installs, we're going to have to think of something.
Comment 2 Jan Sedlák 2012-08-20 03:05:21 EDT
I've got to remind you that in current F18 Alpha TC3, firstboot doesn't display (bug 849118, it doesn't work in LXDE nor XFCE, and I'm unable to install KDE or GNOME), so the current workflow is to install F18, boot again from the DVD, choose "System recovery", chroot into freshly installed system, set root password, reboot, login as root and then use "useradd".

Note You need to log in before you can comment on or make changes to this bug.