This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 849118 - firstboot doesn't run, partly due to use of python-meh which has been ported to GTK+ 3
firstboot doesn't run, partly due to use of python-meh which has been ported ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker F18Blocker-kde
  Show dependency treegraph
 
Reported: 2012-08-17 07:21 EDT by Jan Sedlák
Modified: 2012-08-31 20:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849967 (view as bug list)
Environment:
Last Closed: 2012-08-31 20:27:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2012-08-17 07:21:06 EDT
Description of problem:
I don't know if it happens in other GUIs too (I'm unable to install other GUI than LXDE), but firstboot doesn't show up after installation.

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 18 TC3, LXDE desktop
2. Reboot
  
Actual results:
It boots into console login.

Expected results:
Firstboot should show up.
Comment 1 Jan Sedlák 2012-08-20 06:38:37 EDT
Firstboot didn't showed up in XFCE too. I'm assuming that firstboot doesn't start at all.
Comment 2 Adam Williamson 2012-08-20 19:37:51 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Jan mentioned in the meeting that this also affects a KDE install; he could not test a desktop/GNOME install, due to packaging issues. With the information that KDE (a supported desktop) is affected, the bug was accepted as a blocker per criterion "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account."
Comment 3 Jaroslav Reznik 2012-08-21 06:49:44 EDT
Traceback (most recent call last):
  File "/sbin/firstboot", line 96, in <module>
    frontend.set_lang()
  File "/usr/lib/python2.7/site-packages/firstboot/frontend.py", line 45, in set_lang
    i18n = shlex.split(open(I18N).read())
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/i18n'

CC'in vpodzime as msivak is on vacation.
Comment 4 Jaroslav Reznik 2012-08-21 07:12:59 EDT
And with proper /etc/sysconfig/i18n

Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 104, in <module>
    import meh.ui.gui
  File "/usr/lib/python2.7/site-packages/meh/ui/gui.py", line 23, in <module>
    from gi.repository import Gtk
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))
Comment 5 Vratislav Podzimek 2012-08-21 07:24:55 EDT
(In reply to comment #3)
> Traceback (most recent call last):
>   File "/sbin/firstboot", line 96, in <module>
>     frontend.set_lang()
>   File "/usr/lib/python2.7/site-packages/firstboot/frontend.py", line 45, in
> set_lang
>     i18n = shlex.split(open(I18N).read())
> IOError: [Errno 2] No such file or directory: '/etc/sysconfig/i18n'
This is a bug in Anaconda -- new bug  (#849967) created as a clone of this bug.
Comment 6 Vratislav Podzimek 2012-08-21 07:26:08 EDT
(In reply to comment #4)
> And with proper /etc/sysconfig/i18n
> 
> Traceback (most recent call last):
>   File "/usr/sbin/firstboot", line 104, in <module>
>     import meh.ui.gui
>   File "/usr/lib/python2.7/site-packages/meh/ui/gui.py", line 23, in <module>
>     from gi.repository import Gtk
>   File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in
> <module>
>     from ._gi import _API, Repository
> ImportError: could not import gobject (error was: ImportError('When using
> gi.repository you must not import static modules like "gobject". Please
> change all occurrences of "import gobject" to "from gi.repository import
> GObject".',))
This is caused by importing python-meh which was ported to Gtk3. python-meh's ui has to be removed from firstboot's exception handling.
Comment 7 Adam Williamson 2012-08-21 20:26:43 EDT
What does the 'POST' status on this bug mean? There is no firstboot mailing list that I can find, I do not see a patch for it posted to devel@ or anaconda-devel-list, and I do not see any commit in git. There doesn't appear to be a fedorahosted.org git repo for firstboot-the-code (as opposed to firstboot-the-package). So I cannot figure out where a fix for this bug can possibly be 'POST'ed if it's not in any of those places...
Comment 8 Vratislav Podzimek 2012-08-22 04:28:56 EDT
(In reply to comment #7)
> What does the 'POST' status on this bug mean? There is no firstboot mailing
> list that I can find, I do not see a patch for it posted to devel@ or
> anaconda-devel-list, and I do not see any commit in git. There doesn't
> appear to be a fedorahosted.org git repo for firstboot-the-code (as opposed
> to firstboot-the-package). So I cannot figure out where a fix for this bug
> can possibly be 'POST'ed if it's not in any of those places...
Patch for this issue has been posted to anaconda-patches-list.
Comment 9 Vratislav Podzimek 2012-08-22 05:24:26 EDT
(In reply to comment #7)
> What does the 'POST' status on this bug mean? There is no firstboot mailing
> list that I can find, I do not see a patch for it posted to devel@ or
> anaconda-devel-list, and I do not see any commit in git. There doesn't
> appear to be a fedorahosted.org git repo for firstboot-the-code (as opposed
> to firstboot-the-package). So I cannot figure out where a fix for this bug
> can possibly be 'POST'ed if it's not in any of those places...
git for firstboot-the-code is here:
http://git.fedorahosted.org/git/firstboot.git
Comment 10 Adam Williamson 2012-08-22 19:52:11 EDT
Ah, cool - in that case, the firstboot spec should reflect this. Right now it just says:

# This is a Red Hat maintained package which is specific to
# our distribution.  Thus the source is only available from
# within this srpm.
Source0: %{name}-%{version}.tar.gz

which obviously isn't true any more.
Comment 11 Fedora Update System 2012-08-23 20:43:09 EDT
firstboot-18.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firstboot-18.2-1.fc18
Comment 12 Fedora Update System 2012-08-23 21:23:25 EDT
Package firstboot-18.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-18.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12614/firstboot-18.2-1.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-08-31 20:27:24 EDT
firstboot-18.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.