Bug 849967 - firstboot fails to run partly due to /etc/sysconfig/i18n not being written by anaconda
firstboot fails to run partly due to /etc/sysconfig/i18n not being written by...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Alpha/F18AlphaBlocker F18Blocker-kde
  Show dependency treegraph
 
Reported: 2012-08-21 07:22 EDT by Vratislav Podzimek
Modified: 2012-09-04 17:28 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 849118
Environment:
Last Closed: 2012-09-04 17:28:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vratislav Podzimek 2012-08-21 07:22:22 EDT
+++ This bug was initially created as a clone of Bug #849118 +++

Description of problem:
I don't know if it happens in other GUIs too (I'm unable to install other GUI than LXDE), but firstboot doesn't show up after installation.

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 18 TC3, LXDE desktop
2. Reboot
  
Actual results:
It boots into console login.

Expected results:
Firstboot should show up.

--- Additional comment from jsedlak@redhat.com on 2012-08-20 06:38:37 EDT ---

Firstboot didn't showed up in XFCE too. I'm assuming that firstboot doesn't start at all.

--- Additional comment from awilliam@redhat.com on 2012-08-20 19:37:51 EDT ---

Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Jan mentioned in the meeting that this also affects a KDE install; he could not test a desktop/GNOME install, due to packaging issues. With the information that KDE (a supported desktop) is affected, the bug was accepted as a blocker per criterion "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account."

--- Additional comment from jreznik@redhat.com on 2012-08-21 06:49:44 EDT ---

Traceback (most recent call last):
  File "/sbin/firstboot", line 96, in <module>
    frontend.set_lang()
  File "/usr/lib/python2.7/site-packages/firstboot/frontend.py", line 45, in set_lang
    i18n = shlex.split(open(I18N).read())
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/i18n'

CC'in vpodzime as msivak is on vacation.

--- Additional comment from jreznik@redhat.com on 2012-08-21 07:12:59 EDT ---

And with proper /etc/sysconfig/i18n

Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 104, in <module>
    import meh.ui.gui
  File "/usr/lib/python2.7/site-packages/meh/ui/gui.py", line 23, in <module>
    from gi.repository import Gtk
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))
Comment 1 Vratislav Podzimek 2012-08-21 07:23:12 EDT
(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #849118 +++
> 
> Description of problem:
> I don't know if it happens in other GUIs too (I'm unable to install other
> GUI than LXDE), but firstboot doesn't show up after installation.
> 
> How reproducible:
> Always.
> 
> Steps to Reproduce:
> 1. Install Fedora 18 TC3, LXDE desktop
> 2. Reboot
>   
> Actual results:
> It boots into console login.
> 
> Expected results:
> Firstboot should show up.
> 
> --- Additional comment from jsedlak@redhat.com on 2012-08-20 06:38:37 EDT ---
> 
> Firstboot didn't showed up in XFCE too. I'm assuming that firstboot doesn't
> start at all.
> 
> --- Additional comment from awilliam@redhat.com on 2012-08-20 19:37:51 EDT
> ---
> 
> Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting:
> http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-
> 20-15.00.html . Jan mentioned in the meeting that this also affects a KDE
> install; he could not test a desktop/GNOME install, due to packaging issues.
> With the information that KDE (a supported desktop) is affected, the bug was
> accepted as a blocker per criterion "In most cases (see Blocker_Bug_FAQ), a
> system installed according to any of the above criteria must boot to the
> 'firstboot' utility on the first boot after installation, without unintended
> user intervention, unless the user explicitly chooses to boot in
> non-graphical mode. The firstboot utility must be able to create a working
> user account."
> 
> --- Additional comment from jreznik@redhat.com on 2012-08-21 06:49:44 EDT ---
> 
> Traceback (most recent call last):
>   File "/sbin/firstboot", line 96, in <module>
>     frontend.set_lang()
>   File "/usr/lib/python2.7/site-packages/firstboot/frontend.py", line 45, in
> set_lang
>     i18n = shlex.split(open(I18N).read())
> IOError: [Errno 2] No such file or directory: '/etc/sysconfig/i18n'
This part is a bug in Anaconda which should write out this file.
Comment 2 Adam Williamson 2012-08-21 20:27:28 EDT
What does the POST status on this bug mean? I do not see any patch submitted to anaconda-devel-list for discussion, which is the usual meaning of the status POST as applied to anaconda bugs. Thanks!
Comment 3 Vratislav Podzimek 2012-08-22 04:29:08 EDT
(In reply to comment #2)
> What does the POST status on this bug mean? I do not see any patch submitted
> to anaconda-devel-list for discussion, which is the usual meaning of the
> status POST as applied to anaconda bugs. Thanks!
Patch for this issue has been posted to anaconda-patches-list.
Comment 4 Adam Williamson 2012-08-22 12:57:29 EDT
Discussed at 2012-08-22 blocker review meeting. Accepted as a blocker per criterion "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account".
Comment 5 Fedora Update System 2012-08-23 20:43:04 EDT
firstboot-18.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firstboot-18.2-1.fc18
Comment 6 Fedora Update System 2012-08-23 21:23:19 EDT
Package firstboot-18.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-18.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12614/firstboot-18.2-1.fc18
then log in and leave karma (feedback).
Comment 7 Adam Williamson 2012-08-31 20:04:35 EDT
why is firstboot marked as fixing this, when the point of having separate bugs is that this part of the bug is in anaconda not firstboot?
Comment 8 Fedora Update System 2012-08-31 20:27:18 EDT
firstboot-18.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Kevin Kofler 2012-09-01 14:20:02 EDT
Reopening as per comment #7.
Comment 10 Vratislav Podzimek 2012-09-03 04:29:46 EDT
(In reply to comment #7)
> why is firstboot marked as fixing this, when the point of having separate
> bugs is that this part of the bug is in anaconda not firstboot?
The fix was done in firstboot, because the /etc/sysconfig/i18n file is now obsoleted by /etc/locale.conf which needs some more changes in anaconda and firstboot shouldn't throw an exception until this is fixed in anaconda. Shall I reassign this to firstboot and close this bug as CLOSED ERRATA?
Comment 11 Adam Williamson 2012-09-04 17:28:34 EDT
sure.

Note You need to log in before you can comment on or make changes to this bug.