Bug 849152 - anaconda doesn't use DVD repo
anaconda doesn't use DVD repo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 849466 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-17 09:12 EDT by Petr Schindler
Modified: 2013-01-10 01:53 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 12:20:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-08-17 09:12:08 EDT
Description of problem:
I can't set DVD as installation source. When I start anaconda the closest mirror is set as default. When I go to the installation source spoke, there is checked auto-detected installation media, where is only installation dvd (but it's not highlighted). When I go back to main hub, it still shows that closest mirror is chosen. When I go back to installation source spoke and choose (highlight) dvd and then click on back, it shows 'Fail to set up install source'.

I see two problems in this. First, anaconda is unable to use DVD repo as a source. Second, closest mirror is set as default instead of DVD (it makes sence for now, when DVD source can't be use)

Version-Release number of selected component (if applicable):
anaconda 18.6
Alpha TC3 DVD.iso

How reproducible:
always

Steps to Reproduce:
1. Boot anaconda from DVD.iso, choose language and accept your fate
2. click on 'Installation source'
3. Choose dvd as a source
  
Actual results:
anaconda fails to set up dvd as a installation source

Expected results:
Anaconda should be able to use DVD repo

Additional info:
I propose this as a blocker bug due to criterion:
"When booting from a DVD ISO image, the installer must be able to use the DVD local package source options "
Comment 1 Jesse Keating 2012-08-17 13:39:00 EDT
Can you attach the logs from your install?  There might be something in there about the DVD media.  I'm not sure we've tested with full media though.
Comment 2 Chris Lumens 2012-08-17 16:47:42 EDT
Don't worry about it, I can reproduce.  Sent off a patch I don't really like, but will hopefully spur people into coming up with a better fix.
Comment 3 Jesse Keating 2012-08-20 11:13:13 EDT
*** Bug 849466 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2012-08-20 19:33:55 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a blocker per criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".
Comment 5 Fedora Update System 2012-08-22 18:59:01 EDT
anaconda-18.6.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.1-1.fc18
Comment 6 Fedora Update System 2012-08-23 00:36:36 EDT
Package anaconda-18.6.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12550/anaconda-18.6.1-1.fc18
then log in and leave karma (feedback).
Comment 7 Dan Mashal 2012-09-01 02:46:45 EDT
Appears to be fixed in TC5
Comment 8 Adam Williamson 2012-09-06 12:20:51 EDT
18.6.5 was pushed stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.