Bug 849414 - [abrt] ibus-1.4.99.20120712-3.fc18: main.py:464:__shortcut_button_clicked_cb2:IndexError: list index out of range
[abrt] ibus-1.4.99.20120712-3.fc18: main.py:464:__shortcut_button_clicked_cb2...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:4eafdea2ffe1395b1d47f747526...
:
: 849726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 06:44 EDT by Dodji Seketeli
Modified: 2012-08-24 05:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 05:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (108 bytes, text/plain)
2012-08-19 06:44 EDT, Dodji Seketeli
no flags Details

  None (edit)
Description Dodji Seketeli 2012-08-19 06:44:29 EDT
Description of problem:
I entered an empty keyboard shorcut string into the ibus keyboard shortcut setting text entry field because I wanted to disable that keyboard shortcut and ibus crashed. 

Version-Release number of selected component:
ibus-1.4.99.20120712-3.fc18

Additional info:
libreport version: 2.0.12
abrt_version:   2.0.11
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py ibus-setup
kernel:         3.6.0-0.rc1.git6.1.fc18.x86_64

backtrace:
:main.py:464:__shortcut_button_clicked_cb2:IndexError: list index out of range
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 464, in __shortcut_button_clicked_cb2
:    orig_list = variant.dup_strv()[0]
:IndexError: list index out of range
:
:Local variables in innermost frame:
:name: 'trigger_accel'
:shortcuts: []
:text: ''
:section: 'general/hotkey'
Comment 1 Dodji Seketeli 2012-08-19 06:44:32 EDT
Created attachment 605472 [details]
File: core_backtrace
Comment 2 fujiwara 2012-08-19 21:30:31 EDT
Probably I think this is duplicated with bug 844580.
The workaround is:

1. Modify /etc/dconf/profile/ibus
-user
-ibus
+user-db:user
+systemd-db:ibus

2. Restart ibus-dconf
% ps -ef | grep ibus-dconf
% kill $PID
% env DCONF_PROFILE=ibus /usr/libexec/ibus-dconf &
Comment 3 fujiwara 2012-08-23 04:25:18 EDT
*** Bug 849726 has been marked as a duplicate of this bug. ***
Comment 4 fujiwara 2012-08-23 04:28:08 EDT
Now ibus-1.4.99.20120822-1.fc18 is available.

# yum install --enablerepo=updates-testing ibus

Are you still able to reproduce your problem with the latest ibus?
Comment 5 Dodji Seketeli 2012-08-24 03:44:45 EDT
Sorry for the dumb question, but how do I restart ibus without having to logout/login again?
Comment 6 fujiwara 2012-08-24 03:53:26 EDT
(In reply to comment #5)
> Sorry for the dumb question, but how do I restart ibus without having to
> logout/login again?

If you use panel applications likes gnome-panel, ibus panel icon is shown on the panel application and you could choose right click "Restart".
If you use gnome-shell, there is no ibus specific menu but you could run 'ibus' command line.
% ibus --help
% ibus restart
Comment 7 Dodji Seketeli 2012-08-24 05:23:14 EDT
OK, this update fixes the issue for me, thanks.

Note You need to log in before you can comment on or make changes to this bug.