Bug 849479 - python-novaclient missing dependency on python-setuptools
python-novaclient missing dependency on python-setuptools
Status: CLOSED DUPLICATE of bug 850975
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Yaniv Kaul
Depends On:
  Show dependency treegraph
Reported: 2012-08-19 16:30 EDT by Derek Higgins
Modified: 2016-01-04 09:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-23 18:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2012-08-19 16:30:16 EDT
Using python-novaclient-2012.1-1.el6.noarch on RHEL 6.3

the nova command line tool has a dependency on python-setuptools which isn't installed with the package

[root@rhel63 ~]# yum install python-novaclient
[root@rhel63 ~]# nova
Traceback (most recent call last):
  File "/usr/bin/nova", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

[root@rhel63 ~]# yum install python-setuptools 
[root@rhel63 ~]# nova
usage: nova [--debug] [--os_username OS_USERNAME] [--os_password OS_PASSWORD]
Comment 1 Alan Pevec 2012-08-23 18:28:57 EDT

*** This bug has been marked as a duplicate of bug 850975 ***

Note You need to log in before you can comment on or make changes to this bug.