Bug 850975 - python-novaclient missing dependency on python-setuptools
python-novaclient missing dependency on python-setuptools
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
unspecified Severity low
: ---
: 2.0 Folsom
Assigned To: Pádraig Brady
Yaniv Kaul
:
: 849479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 20:35 EDT by Pádraig Brady
Modified: 2016-01-04 09:46 EST (History)
3 users (show)

See Also:
Fixed In Version: python-novaclient-2.10.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 849477
Environment:
Last Closed: 2012-12-13 09:28:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2012-08-22 20:35:18 EDT
+++ This bug was initially created as a clone of Bug #849477 +++

[root@f17 ~]# yum install python-novaclient
[root@f17 ~]# nova
Traceback (most recent call last):
  File "/bin/nova", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources


[root@f17 ~]# yum install python-setuptools 
[root@f17 ~]# nova
usage: nova [--debug] [--os_username OS_USERNAME] [--os_password OS_PASSWORD]

--- Additional comment from pbrady@redhat.com on 2012-08-19 23:03:56 EDT ---

Hmm I might just remove the install_requires from setup.py
That seems at first glance redundant with distro packaging.

--- Additional comment from apevec@gmail.com on 2012-08-22 09:41:51 EDT ---

Not sure if install_requires will help, client binary (in all nova/glance/keystone/quantum clients) is actually generated by setuptools and uses pkg_resources.load_entry_point

Let's just add setuptools as a runtime dependency in all clients, I'll clone this to other OpenStack *client components.

--- Additional comment from updates@fedoraproject.org on 2012-08-22 12:30:31 EDT ---

python-novaclient-2012.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-novaclient-2012.1-2.fc17

--- Additional comment from updates@fedoraproject.org on 2012-08-22 12:51:24 EDT ---

python-novaclient-2012.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-novaclient-2012.1-2.el6
Comment 1 Alan Pevec 2012-08-23 18:28:57 EDT
*** Bug 849479 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.