Bug 849632 - PXE + inst.repo doesn't boot
PXE + inst.repo doesn't boot
Status: CLOSED DUPLICATE of bug 849672
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
Reported: 2012-08-20 08:00 EDT by Kamil Páral
Modified: 2012-08-28 16:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-28 16:20:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
boot.log (25.53 KB, text/plain)
2012-08-20 08:01 EDT, Kamil Páral
no flags Details
boot-debug.log (1.00 MB, text/plain)
2012-08-20 08:01 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-08-20 08:00:18 EDT
Description of problem:
If I boot vmlinuz+initrd and provide inst.repo=http://repo argument to the kernel line, anaconda fails to boot. The problem is probably in dracut, it doesn't download the stage2 image.

> dracut-initqueue[290]: Warning: Could not boot.
> dracut-initqueue[290]: Warning: /dev/root does not exist
> Entering emergency mode. Exit the shell to continue.
> Type "journalctl" to view system logs.
> dracut:/#        

Version-Release number of selected component (if applicable):
F18 Alpha TC3

How reproducible:
Comment 1 Kamil Páral 2012-08-20 08:01:30 EDT
Created attachment 605687 [details]
Comment 2 Kamil Páral 2012-08-20 08:01:34 EDT
Created attachment 605688 [details]
Comment 3 Kamil Páral 2012-08-20 08:06:03 EDT
I tried inst.repo=ftp://, it doesn't work either.

Nominating as Alpha blocker:

" The installer must be able to use at least one of the HTTP or FTP remote package source options "
Comment 4 Chris Lumens 2012-08-20 09:02:50 EDT
That's a really broad criterion, though, and you should still be able to use the UI to enter an HTTP/FTP source which would therefore take care of that.
Comment 5 Kamil Páral 2012-08-20 09:50:11 EDT
To tell the truth, I'm not sure whether that criterion refers to adding a custom repository in the UI or to the kernel boot options. PXE boot itself is listed in Beta criteria. Let's discuss at blocker bug meeting.
Comment 6 Adam Williamson 2012-08-20 19:35:43 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a Beta blocker per criterion "It must be possible to install by booting the installation kernel directly, including via PXE, and correctly specifying a remote source for the installer itself, using whichever protocols are required to work for package retrieval at the current phase (Alpha, Beta, Final)..." - that's really what this bug is about, the repo is being used as a source for the installer, not just for packages. This bug does not necessarily indicate that inst.repo= doesn't work as a simple package source.
Comment 7 Will Woods 2012-08-28 16:20:23 EDT
'set_neednet' was broken, so the network never came up, so nothing ever got fetched.

*** This bug has been marked as a duplicate of bug 849672 ***

Note You need to log in before you can comment on or make changes to this bug.