Bug 849672 - Network is not started when ip= parameter is not specified during installation
Network is not started when ip= parameter is not specified during installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 849632 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-20 10:16 EDT by Martin Banas
Modified: 2012-09-17 18:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849675 (view as bug list)
Environment:
Last Closed: 2012-09-17 18:55:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gzipped logfile without ip= parameter (49.31 KB, application/x-compressed-tar)
2012-08-20 10:16 EDT, Martin Banas
no flags Details
gzipped logfile with ip=dhcp parameter (50.29 KB, application/x-compressed-tar)
2012-08-20 10:17 EDT, Martin Banas
no flags Details
gzipped logfile with ip=eth0:dhcp parameter (34.31 KB, application/x-compressed-tar)
2012-08-20 10:17 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2012-08-20 10:16:15 EDT
Created attachment 605713 [details]
gzipped logfile without ip= parameter

Description of problem:
When we start installation of Fedora-18 one of following cmdlines, network is not started and user is dropped to debug shell:

1.) rd.debug repo=http://dl.fedoraproject.org/pub/alt/stage/18-Alpha-TC3/Fedora/x86_64/os/
2.) rd.debug repo=http://dl.fedoraproject.org/pub/alt/stage/18-Alpha-TC3/Fedora/x86_64/os/ ip=dhcp

This used to work previously, in RHEL-7 and also in Fedora.

Version-Release number of selected component (if applicable):
Fedora 18-Alpha-TC3
dracut-023-2.fc18
anaconda-18.6

How reproducible:
always

Steps to Reproduce:
1. Boot the installation with one of the 2 cmdlines from Description
2. You will be dropped to debug shell since the network is not set up.
  
Actual results:
User is dropped to debug shell, network is not configured.

Expected results:
Installation should start network if needed.

Additional info:
If I use ip=eth0:dhcp, everything works OK.
Comment 1 Martin Banas 2012-08-20 10:17:15 EDT
Created attachment 605714 [details]
gzipped logfile with ip=dhcp parameter

This one is with ip=dhcp parameter, doesn't work too.
Comment 2 Martin Banas 2012-08-20 10:17:58 EDT
Created attachment 605715 [details]
gzipped logfile with ip=eth0:dhcp parameter

This one is working fine.
Comment 3 Will Woods 2012-08-20 12:44:22 EDT
Yeah, there were some changes in the way you tell dracut to bring up the network (the rd.neednet argument is no longer used).

I've got a patch that should fix this: https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-August/000638.html

It should be pushed to git shortly and will probably be in the next anaconda build.
Comment 4 Harald Hoyer 2012-08-21 14:07:49 EDT
dracut-023-13.git20120821.fc18
Comment 5 Fedora Update System 2012-08-22 18:58:36 EDT
anaconda-18.6.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.1-1.fc18
Comment 6 Will Woods 2012-08-28 16:20:23 EDT
*** Bug 849632 has been marked as a duplicate of this bug. ***
Comment 7 Kamil Páral 2012-08-29 08:33:42 EDT
Transferring blocker status from bug 849632. Setting state to ON_QA, we need to verify this in the next TC.
Comment 8 Adam Williamson 2012-08-31 16:15:42 EDT
TC4 should include this, so please re-test.
Comment 9 Martin Banas 2012-09-03 02:37:54 EDT
Retested on TC5, both cmdlines from description now works without issues.

Thank you.
Comment 10 Kamil Páral 2012-09-03 04:09:17 EDT
Yes, PXE + inst.repo=http:// seems to work with Alpha TC5.
Comment 11 Adam Williamson 2012-09-17 18:55:33 EDT
18.6.7 went stable, so closing this.

Note You need to log in before you can comment on or make changes to this bug.