This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 849997 - anaconda freezed after boot
anaconda freezed after boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-21 08:55 EDT by Jan Sedlák
Modified: 2012-09-05 20:53 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.6.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 20:53:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda exception report (169.82 KB, text/plain)
2012-08-21 08:55 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-08-21 08:55:18 EDT
Created attachment 605930 [details]
anaconda exception report

Description of problem:
When I tried to reproduce bug 849563, once it happened that after choosing language and clicking on "continue" GUI freezed. I was able to switch to console, but GUI didn't react. I was able to collect anaconda exception report from /tmp, see attachment.
Comment 1 Vratislav Podzimek 2012-08-29 05:14:30 EDT
This happens if unhandled exception appears in a separate thread (not the main one). Patch has been reviewed and pushed to anaconda git repository.
Comment 2 Vratislav Podzimek 2012-08-29 05:24:40 EDT
Proposing this as an Alpha blocker according to this criteria:
>"The installer must be able to report failures to Bugzilla and local disk, with appropriate information included."

Because if failure appears in a separate thread (there are lot of them now in anaconda), installer is unable to report it to Bugzilla.
Comment 3 Adam Williamson 2012-08-29 12:35:41 EDT
Discussed at 2012-08-29 blocker review meeting. Accepted as a blocker per criterion "The installer must be able to report failures to Bugzilla and local disk, with appropriate information included".
Comment 4 Fedora Update System 2012-09-01 01:12:04 EDT
anaconda-18.6.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.5-1.fc18
Comment 5 Kamil Páral 2012-09-03 05:09:06 EDT
Vratislav says this should be fixed in 18.6.2 according to changelog, which is definitely included in Alpha TC5. But it's hard to test the fix, the only way is to build a custom updates.img. One of anaconda developers has to test this, or we can just close it and believe (and reopen if we see it again).
Comment 6 Fedora Update System 2012-09-05 20:53:41 EDT
anaconda-18.6.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.