Bug 850121 - Error while parsing command line options
Error while parsing command line options
Status: CLOSED DUPLICATE of bug 889150
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
17
All All
unspecified Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 09:37 EDT by Michal Sekletar
Modified: 2013-01-10 01:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-27 22:10:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Added explicit string constructor call (561 bytes, patch)
2012-08-21 09:37 EDT, Michal Sekletar
no flags Details | Diff

  None (edit)
Description Michal Sekletar 2012-08-21 09:37:36 EDT
Created attachment 605939 [details]
Added explicit string constructor call

Description of problem:
--blocked command line option doesn't handle its arguments properly

Version-Release number of selected component (if applicable):
python-bugzilla-0.7.0-1.fc17.noarch

Steps to Reproduce:
1. Login
2. Try to file new bug with --blocked set to some tracking bug id
3. Observe results
  
Actual results:
Exception raised

Expected results:
Should work

Additional info:
Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 808, in <module>
    main()
  File "/usr/bin/bugzilla", line 588, in main
    data[a] = i.split(',')
AttributeError: 'NoneType' object has no attribute 'split'
Comment 1 Cole Robinson 2012-12-27 22:09:11 EST
Thanks for the patch Michal, this is actually already fixed upstream, will be fixed with the next Fedora update.
Comment 2 Cole Robinson 2012-12-27 22:10:06 EST

*** This bug has been marked as a duplicate of bug 889150 ***

Note You need to log in before you can comment on or make changes to this bug.