Bug 889150 - [patch] python-bugzilla: traceback with certain arguments trying to split None
[patch] python-bugzilla: traceback with certain arguments trying to split None
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 850121 895254 902426 914780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 05:46 EST by Stanislav Ochotnicky
Modified: 2016-04-26 15:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 17:01:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to verify we are not splitting None (730 bytes, patch)
2012-12-20 05:46 EST, Stanislav Ochotnicky
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2012-12-20 05:46:13 EST
Created attachment 666584 [details]
Patch to verify we are not splitting None

Description of problem:
python-bugzilla fails with certain arguments when trying to split None

for p in `repoquery --repoid rawhide -s --whatrequires maven-doxia | sed 's|-[^-]*-[^-]*$||' | sort -u`; do bugzilla new -p Fedora -v rawhide -c $p --cc msrb@redhat.com -s "$p: Migrate from maven-doxia to doxia subpackages" -l "maven-doxia was split into multiple subpackages. Your package currently requires or build-requires maven-doxia. Please fix your requires or build requires of your package $p so that it requires proper subpackages of doxia."; done

This results in 

Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 808, in <module>
    main()
  File "/usr/bin/bugzilla", line 588, in main
    data[a] = i.split(',')
AttributeError: 'NoneType' object has no attribute 'split'


I've attached an upstream patch to verify we have valid variable before trying to split it

Version-Release number of selected component (if applicable):
python-bugzilla-0.7.0-2.fc18.noarch and master branch upstream
Comment 1 Cole Robinson 2012-12-27 17:27:32 EST
Thanks for the patch Stanislav, this was inadvertently fixed upstream a few days ago. Update coming soon.
Comment 2 Cole Robinson 2012-12-27 22:10:06 EST
*** Bug 850121 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2013-01-14 18:55:51 EST
*** Bug 895254 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2013-01-24 14:28:54 EST
*** Bug 902426 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-02-16 10:21:23 EST
python-bugzilla-0.8.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-bugzilla-0.8.0-1.fc18
Comment 6 Cole Robinson 2013-02-26 18:58:48 EST
*** Bug 914780 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-03-04 17:13:19 EST
python-bugzilla-0.8.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-bugzilla-0.8.0-2.fc18
Comment 8 Fedora Update System 2013-03-05 18:25:18 EST
Package python-bugzilla-0.8.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-bugzilla-0.8.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3447/python-bugzilla-0.8.0-2.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-03-22 17:01:08 EDT
python-bugzilla-0.8.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.