Bug 850632 - [abrt] gimp-2.8.0-1.fc17: g_logv: Process /usr/bin/gimp-2.8 was killed by signal 5 (SIGTRAP)
[abrt] gimp-2.8.0-1.fc17: g_logv: Process /usr/bin/gimp-2.8 was killed by sig...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:f5b1601dc7425085840247eadd1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 23:49 EDT by Jeff Raber
Modified: 2013-08-01 01:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 01:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (8.07 KB, text/plain)
2012-08-21 23:49 EDT, Jeff Raber
no flags Details
File: backtrace (70.43 KB, text/plain)
2012-08-21 23:49 EDT, Jeff Raber
no flags Details
File: maps (52.59 KB, text/plain)
2012-08-21 23:49 EDT, Jeff Raber
no flags Details
File: dso_list (9.83 KB, text/plain)
2012-08-21 23:49 EDT, Jeff Raber
no flags Details

  None (edit)
Description Jeff Raber 2012-08-21 23:49:00 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gimp-2.8 --debug-handlers --g-fatal-warnings --verbose
crash_function: g_logv
executable:     /usr/bin/gimp-2.8
kernel:         3.5.1-1.fc17.x86_64
pid:            16731
pwd:            /home/jeff
remote_result:  NOTFOUND
time:           Tue 21 Aug 2012 09:50:54 PM CDT
uid:            1000
username:       jeff

backtrace:      Text file, 72122 bytes
core_backtrace: Text file, 8263 bytes
dso_list:       Text file, 10064 bytes
maps:           Text file, 53848 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jeff/1

comment:
:Opened gimp.
:Loaded a .XCF file
:Pressed 'Save as..."
:Tried to save as a .png, got the message that I need to use 'File > export' to save in a format other than .XCF
:Hit cancel, and it crashed.

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=trinity2
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/jeff/keyring-8Ai5eq/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=ed873f3717395d47a5e9419d0000000e-1345250117.800329-413421160
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=35651589
:GNOME_KEYRING_CONTROL=/run/user/jeff/keyring-8Ai5eq
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=jeff
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.htm=00;33:*.html=00;33:*.shtml=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/run/user/jeff/keyring-8Ai5eq/ssh
:USERNAME=jeff
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1211,unix/unix:/tmp/.ICE-unix/1211
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/jeff/.local/bin:/home/jeff/bin
:MAIL=/var/spool/mail/jeff
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/jeff
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/jeff
:XDG_SEAT=seat0
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=jeff
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ajwRzokcDu,guid=8602073c267c0d96b134096d0000000e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/jeff
:DISPLAY=:0
:CCACHE_HASHDIR=
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-jeff-0cl915/database
:_=/usr/bin/gimp-2.8

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 256989               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       256989               256989               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/1
:pos:	0
:flags:	0100002
:1:/dev/pts/1
:pos:	0
:flags:	0100002
:2:/dev/pts/1
:pos:	0
:flags:	0100002
:3:socket:[26836612]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[26835151]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[26835152]
:pos:	0
:flags:	02004002
:8:socket:[26835154]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[26836707]
:pos:	0
:flags:	02004002
:11:anon_inode:inotify
:pos:	0
:flags:	02004000
:12:pipe:[26837544]
:pos:	0
:flags:	00
:13:socket:[26838692]
:pos:	0
:flags:	02004002
:14:socket:[26835936]
:pos:	0
:flags:	02
:15:pipe:[26837545]
:pos:	0
:flags:	01
:16:socket:[26835937]
:pos:	0
:flags:	02004002
:17:/home/jeff/.gimp-2.8/gimpswap.16731
:pos:	46137344
:flags:	0100002

var_log_messages:
:Aug 21 08:41:22 trinity2 kernel: [245528.780964] gimp-2.8[11056]: segfault at 0 ip 00007fe529fcb4d1 sp 00007ffff7b11308 error 4 in libc-2.15.so[7fe529e6c000+1ac000]
:Aug 21 08:41:24 trinity2 abrt[11726]: Saved core dump of pid 11056 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-21-08:41:22-11056 (307339264 bytes)
:Aug 21 18:19:14 trinity2 kernel: [258145.410031] gimp-2.8[14640]: segfault at 0 ip 00007ffc8f1c94d1 sp 00007fff309f9dd8 error 4 in libc-2.15.so[7ffc8f06a000+1ac000]
:Aug 21 18:19:15 trinity2 abrt[14669]: Saved core dump of pid 14640 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-21-18:19:14-14640 (203583488 bytes)
:Aug 21 18:19:55 trinity2 kernel: [258185.775838] gimp-2.8[14777]: segfault at 0 ip 00007fd66fa264d1 sp 00007fffbb123c88 error 4 in libc-2.15.so[7fd66f8c7000+1ac000]
:Aug 21 18:19:56 trinity2 abrt[14802]: Saved core dump of pid 14777 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-21-18:19:55-14777 (195678208 bytes)
:Aug 21 21:50:54 trinity2 kernel: [264335.303713] gimp-2.8[16731] trap int3 ip:7f014e047801 sp:7fff96af71e0 error:0
:Aug 21 21:50:55 trinity2 abrt[16764]: Saved core dump of pid 16731 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-21-21:50:54-16731 (203952128 bytes)
Comment 1 Jeff Raber 2012-08-21 23:49:03 EDT
Created attachment 606110 [details]
File: core_backtrace
Comment 2 Jeff Raber 2012-08-21 23:49:06 EDT
Created attachment 606111 [details]
File: backtrace
Comment 3 Jeff Raber 2012-08-21 23:49:08 EDT
Created attachment 606112 [details]
File: maps
Comment 4 Jeff Raber 2012-08-21 23:49:10 EDT
Created attachment 606113 [details]
File: dso_list
Comment 5 Jeff Raber 2012-08-21 23:51:33 EDT
This is related to bug 846089

This is 100% reproducible for me.

The steps to reproduce are the same as bug 846089 The crash is different here because I ran gimp with the parameters '--debug-handlers --g-fatal-warnings --verbose'
Comment 6 Nils Philippsen 2012-11-06 11:44:16 EST
I couldn't reproduce this bug with gimp version 2.8.2, and bug #846089 doesn't seem related (it's a rhythmbox bug). Can you still reproduce this?
Comment 7 Fedora End Of Life 2013-07-03 21:25:55 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2013-08-01 01:49:36 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.