Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 85067 - Cannot Allocate Memory Error during installation of Red Hat Linux!!
Cannot Allocate Memory Error during installation of Red Hat Linux!!
Status: CLOSED DUPLICATE of bug 76123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-25 05:35 EST by urvish jani
Modified: 2007-03-27 00:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description urvish jani 2003-02-25 05:35:58 EST
Description of problem:
file "/usr/anaconda/gui.py", line 786 in handleRenderCallback
      Self.CurrentWindow.renderCallback()
file "/usr/lib/anaconda/iw/progress_gui.py", line 149, in 
renderCallbackself.intf.icw.nextClicked()

file "/usr/lib/anaconda/gui.py", line 632, in nextClickedself.dispatch.gotonext
()
file "/usr/lib/anaconda/dispatch.py", line 150, in gotoNextself.movestep()
file "/usr/lib/anaconda/dispatch.py", line 215 in moveStep
  rc=applx(func,self.bindArgs(args))
file "/usr/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetadeletes (diskset)
file "/usr/lib/anaconda/partions.py", line 1110, in doMetaDeletes
lvm.Vgactivate
file "/usr/lib/anaconda/lvm.py", line 54 in vgactivate
  searchPath=1)  ** note single bracket **
file "/usr/lib/anaconda/iutil.py", line 66, in execwithRedirect
   childpid=OS.fork()
OSError: [Errno 12] Cannot allocate memory



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:

There is error and it will not allow me to move towards installation!
Expected results:
The installation should be started!

Additional info:
Comment 1 Michael Lee Yohe 2003-02-25 09:20:59 EST
This appears to be a duplicate of Bug 76123.  Most "cannot allocate memory"
problem during install are related to the aforementioned bug.  The problem is
that there is not enough memory to process the transactions that are to be
executed by the installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.
Comment 2 Michael Fulbright 2003-04-22 12:18:21 EDT

*** This bug has been marked as a duplicate of 76123 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.