Bug 850719 - Internal error while running pool VM created from template that was created from a VM with native usb redirection: internal error PIIX3 USB controller must have PCI address 0:0:1.2.
Internal error while running pool VM created from template that was created f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Oved Ourfali
Lukas Svaty
virt
: Regression
: 860689 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 04:44 EDT by Tomas Dosek
Modified: 2015-09-22 09 EDT (History)
15 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (1.24 MB, application/zip)
2012-08-22 04:44 EDT, Tomas Dosek
no flags Details

  None (edit)
Description Tomas Dosek 2012-08-22 04:44:58 EDT
Created attachment 606174 [details]
Logs

Description of problem:
When user tries to run a pool VM from a template, which was created from a VM with native USB redirection, this operation fails with internal error.

The error is: internal error PIIX3 USB controller must have PCI address 0:0:1.2.

I see two problems here:
1) USB redirection settings is not transfered to template settings (at least isn't displayed that way in webadmin)
2) In case that Pool's Console settings is set to disable USB redirection (default for pool creation) it shouldn't apply

Version-Release number of selected component (if applicable):
si15

How reproducible:
100 %

Steps to Reproduce:
1. Create a VM - have Native USB redirection set on it
2. Create a template from this VM (check the usb redirection - it's not in template as described in #1)
3. Create a pool from the template (with default settings to disable USB redirection)
4. Assign the pool to some user and try to run the pool VM.
  
Actual results:
Template doesn't copy USB redirection settings
While running the VM QEMU error pops up in event log - vm fails to run

Expected results:
Template should copy USB redirection settings of original VM.

VM should run with a) USB redirection disabled in case that it's disabled during pool's creation, b) with USB redirection enabled in native mode in case it wasn't and the template contains the settings

Additional info:
Attaching logs of the run failure.
Comment 2 Oved Ourfali 2012-08-28 11:33:04 EDT
Posted patch: http://gerrit.ovirt.org/#/c/7544
Comment 3 Oved Ourfali 2012-08-29 03:55:38 EDT
Commit: 95d556e0e8f036f34c066747576e529a5b2ff1e0

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=95d556e0e8f036f34c066747576e529a5b2ff1e0
Comment 6 Itamar Heim 2012-09-26 19:20:43 EDT
*** Bug 860689 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.