Bug 860689 - Pool VM will not start - USB configuration error
Pool VM will not start - USB configuration error
Status: CLOSED DUPLICATE of bug 850719
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 09:40 EDT by Koen van Bakel
Modified: 2012-09-26 19:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 19:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Koen van Bakel 2012-09-26 09:40:27 EDT
Description of problem:
I created a Windows 7 64bit VM with Native USB support. (and this VM works correctly) From that VM I created a template. Changed the USB support to Disabled in the template and then defined a VM Pool based on this template. VM's are being created but if I start a VM it will fail.

VDSM log message: virNetClientProgramDispatchError:174 : internal error PIIX3 USB controller must have PCI address 0:0:1.2

Version-Release number of selected component (if applicable):

RHEVM: 3.1.0.14-el6ev

How reproducible:

Always. (I found the bug in my own setup and also in another environment we experiance the same problem.)

Steps to Reproduce:
1.Create Windows 64bit VM - USB support Native
2.Create template based on previous created VM
3.Change template USB support to Disabled
4.Create Pool based on Template
5.Start VM from Pool.
  
Actual results:
VM from Pool will not start

Expected results:
VM should start correctly

Additional info:

I did some additional scenario testing:

1. Base VM Windows 64 bit: USB Disabled
   Template : USB Disabled
   Pool : USB Disabled

   Result: VM starts correctly.

2. Base VM Windows 64 bit: USB Disabled
   Template : USB Disabled
   Pool : USB Native

   Result: VM fails to start.
   Additional info: in this last scenario you get a different message in the log: virNetClientProgramDispatchError:174 : internal error Process exited while reading console log output: qemu-kvm : -device piix3-usb-uhci, id=usb, bus=pci.0,addr=0x1.0x2:Duplicate ID 'usb' for device.
Comment 1 Itamar Heim 2012-09-26 19:20:42 EDT

*** This bug has been marked as a duplicate of bug 850719 ***

Note You need to log in before you can comment on or make changes to this bug.