Bug 850863 - category create fails
category create fails
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On:
Blocks: 848520 850902
  Show dependency treegraph
 
Reported: 2012-08-22 10:56 EDT by Preethi Thomas
Modified: 2013-09-09 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 850902 (view as bug list)
Environment:
Last Closed: 2013-01-09 12:03:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-22 10:56:51 EDT
Description of problem:

repo uploads category fails to create.

Version-Release number of selected component (if applicable):

[root@pulp-candidate scripts]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.1-1.fc17.noarch
How reproducible:


Steps to Reproduce:
1. create a repo 
2. try to create a create a category
3.
  
Actual results:
[root@pulp-candidate scripts]# pulp-admin repo uploads category  create --repo-id pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log.



Expected results:

Category successully created.

Additional info:

2012-08-22 10:51:31,969 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 475, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 891, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 184, in execute
    return self.method(*arg_list, **clean_kwargs)
TypeError: create() takes exactly 1 argument (9 given)
2012-08-22 10:54:53,932 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 475, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 891, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 184, in execute
    return self.method(*arg_list, **clean_kwargs)
TypeError: create() takes exactly 1 argument (9 given)
Comment 1 Jay Dobies 2012-08-22 11:07:22 EDT
This looks like the issue we've seen previously when extra stuff is passed to the argument and okaara assumes it was intentional, but it's not exactly the same. I'll take a look at the two together.
Comment 2 Jay Dobies 2012-09-04 13:48:35 EDT
commit d8041b621da6cc2b205f772b379eeac192d8a706
Author: Jay Dobies <jason.dobies@redhat.com>
Date:   Tue Sep 4 13:45:56 2012 -0400

    850863 - Print usage if a non-kwarg is specified

platform/src/pulp/client/extensions/extensions.py
Comment 3 Jeff Ortel 2012-09-07 13:45:06 EDT
build: 2.0.3.
Comment 4 Preethi Thomas 2012-09-10 14:57:24 EDT
verified
[root@pulp-candidate ~]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.3-1.fc17.noarch
[root@pulp-candidate ~]# 

[root@pulp-candidate ~]# pulp-admin repo uploads category  create --repo-id  pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
Command: category
Description: create a package category in a repository

Available Arguments:

  --repo-id         - (required) identifies the repository the package category
                      will be created in
  --category-id, -i - (required) id of this package category
  --name, -n        - (required) name of this package category
  --description, -d - (required) description of this package category
  --display-order   - display order for this package category
  --group, -g       - package group ids to include in this package category
  -v                - display extra information about the creation process
[root@pulp-candidate ~]# 
[root@pulp-candidate ~]# 
[root@pulp-candidate ~]# pulp-admin repo uploads category  --repo-id  pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
+----------------------------------------------------------------------+
                       Package Category Creation
+----------------------------------------------------------------------+

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed

[root@pulp-candidate ~]#
Comment 5 Preethi Thomas 2013-01-09 12:03:50 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.