Bug 850897 - [abrt] mysql-workbench-5.2.42-1.fc17.remi: Process /usr/lib64/mysql-workbench/mysql-workbench-bin was killed by signal 11 (SIGSEGV)
[abrt] mysql-workbench-5.2.42-1.fc17.remi: Process /usr/lib64/mysql-workbench...
Status: CLOSED DUPLICATE of bug 851283
Product: Fedora
Classification: Fedora
Component: mysql-workbench (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
abrt_hash:1d033601e367f63eea7f2072a6f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 12:49 EDT by brian
Modified: 2012-08-29 06:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 06:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (4.08 KB, text/plain)
2012-08-22 12:50 EDT, brian
no flags Details
File: backtrace (69.64 KB, text/plain)
2012-08-22 12:50 EDT, brian
no flags Details
File: maps (76.53 KB, text/plain)
2012-08-22 12:50 EDT, brian
no flags Details
File: dso_list (15.81 KB, text/plain)
2012-08-22 12:50 EDT, brian
no flags Details
File: build_ids (6.13 KB, text/plain)
2012-08-22 12:50 EDT, brian
no flags Details

  None (edit)
Description brian 2012-08-22 12:49:59 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/mysql-workbench/mysql-workbench-bin
crash_function: MySQL55TreeWalker::get_next(ANTLR3_BASE_TREE_struct*, bool)
executable:     /usr/lib64/mysql-workbench/mysql-workbench-bin
kernel:         3.5.2-1.fc17.x86_64
pid:            26178
pwd:            /home/bkatke
remote_result:  NOTFOUND
time:           Wed 22 Aug 2012 12:36:26 PM EDT
uid:            1000
username:       bkatke

backtrace:      Text file, 71315 bytes
build_ids:      Text file, 6273 bytes
dso_list:       Text file, 16189 bytes
environ:        Text file, 4183 bytes
maps:           Text file, 78370 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/bkatke/1

core_backtrace:
:41686d2dc452239a01723a1b39245f7a944fc724 0xd8404 MySQL55TreeWalker::get_next(ANTLR3_BASE_TREE_struct*, libmysql55parser.so.0 -
:41686d2dc452239a01723a1b39245f7a944fc724 0xd8689 MySQL55TreeWalker::advance_to_position(int, libmysql55parser.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x3b47e5 Sql_editor::show_auto_completion(bool) libwbpublic.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x3a4e4e Sql_editor::on_sql_check_progress(float, libwbpublic.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x31e32c boost::function2<int, libwbpublic.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x2ca410 boost::signals2::detail::signal1_impl<void, libwbpublic.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x2c104d bec::GRTTask::process_message_m(grt::Message libwbpublic.so.0 -
:639ec4dad81a0232b2b1766a0eead5992ae846f3 0x4607b8 boost::function0<void>::operator()() [exe] -
:5e995b99448f3f00c70567737797f830d09ad72c 0x2bf43d bec::GRTDispatcher::flush_pending_callbacks() libwbpublic.so.0 -
:5e995b99448f3f00c70567737797f830d09ad72c 0x2d1b9e bec::GRTManager::perform_idle_tasks() libwbpublic.so.0 -
:639ec4dad81a0232b2b1766a0eead5992ae846f3 0x60365a wb::WBContext::flush_idle_tasks() [exe] -
:639ec4dad81a0232b2b1766a0eead5992ae846f3 0x40a0bd sigc::internal::slot_call0<sigc::bind_return_functor<bool, [exe] -
:f3cd3b4e0a6c31e9af1598f478198ab0f52b6ca9 0x49502 - libglibmm-2.4.so.1 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14ac57 gtk_main libgtk-x11-2.0.so.0 -
:639ec4dad81a0232b2b1766a0eead5992ae846f3 0x400783 main [exe] -

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30755                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30755                30755                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/1
:pos:	0
:flags:	0102002
:1:/dev/pts/1
:pos:	0
:flags:	0102002
:2:/dev/pts/1
:pos:	0
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[1744825]
:pos:	0
:flags:	02000000
:5:pipe:[1744825]
:pos:	0
:flags:	02000001
:6:socket:[1744826]
:pos:	0
:flags:	02004002
:7:/tmp/mysql-workbench.bkatke/6bfb9fd4-ec77-11e1-b5b1-1040f3932682.db
:pos:	7168
:flags:	02100002
:8:/tmp/mysql-workbench.bkatke/6c49c010-ec77-11e1-b5b1-1040f3932682.db
:pos:	7168
:flags:	02100002
:9:socket:[1744842]
:pos:	0
:flags:	02004002
:10:anon_inode:inotify
:pos:	0
:flags:	02004000
:11:/dev/urandom
:pos:	0
:flags:	02100000
:12:/tmp/mysql-workbench.bkatke/6c4a1be6-ec77-11e1-b5b1-1040f3932682.db
:pos:	7168
:flags:	02100002
:13:/tmp/mysql-workbench.bkatke/6c5376a0-ec77-11e1-b5b1-1040f3932682.db
:pos:	7168
:flags:	02100002
:14:/usr/share/mysql-workbench/sshtunnel.py
:pos:	16071
:flags:	0100000
:15:socket:[1755222]
:pos:	0
:flags:	02004002
:16:/dev/urandom
:pos:	0
:flags:	02100000
:17:socket:[1687546]
:pos:	0
:flags:	02
:18:socket:[1758563]
:pos:	0
:flags:	04002
:19:/dev/urandom
:pos:	0
:flags:	0100000
:20:socket:[1757161]
:pos:	0
:flags:	02
:21:socket:[1745362]
:pos:	0
:flags:	02
:22:socket:[1758657]
:pos:	0
:flags:	02
:23:pipe:[1758658]
:pos:	0
:flags:	00
:24:pipe:[1758658]
:pos:	0
:flags:	01
:25:socket:[1755666]
:pos:	0
:flags:	02
:26:socket:[1759273]
:pos:	0
:flags:	02
:27:pipe:[1759274]
:pos:	0
:flags:	00
:28:pipe:[1759274]
:pos:	0
:flags:	01
:29:/home/bkatke/.mysql/workbench/cache/support.medhub.com.cache
:pos:	5120
:flags:	02100002

var_log_messages:
:Aug 20 14:02:42 bkatke abrt[4754]: Saved core dump of pid 4708 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-20-14:02:41-4708 (84639744 bytes)
:Aug 20 15:59:03 bkatke abrt[8102]: Saved core dump of pid 7469 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-20-15:59:01-7469 (208412672 bytes)
:Aug 20 15:59:51 bkatke abrt[10526]: Saved core dump of pid 10487 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-20-15:59:49-10487 (140664832 bytes)
:Aug 20 16:01:20 bkatke abrt[13213]: Saved core dump of pid 13149 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-20-16:01:18-13149 (133062656 bytes)
:Aug 21 10:07:53 bkatke abrt[18384]: Saved core dump of pid 18347 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-21-10:07:51-18347 (126279680 bytes)
:Aug 22 12:36:29 bkatke abrt[26231]: Saved core dump of pid 26178 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-22-12:36:26-26178 (104898560 bytes)
Comment 1 brian 2012-08-22 12:50:02 EDT
Created attachment 606335 [details]
File: environ
Comment 2 brian 2012-08-22 12:50:04 EDT
Created attachment 606336 [details]
File: backtrace
Comment 3 brian 2012-08-22 12:50:05 EDT
Created attachment 606337 [details]
File: maps
Comment 4 brian 2012-08-22 12:50:07 EDT
Created attachment 606338 [details]
File: dso_list
Comment 5 brian 2012-08-22 12:50:09 EDT
Created attachment 606339 [details]
File: build_ids
Comment 6 Paulo Santos 2012-08-29 06:18:55 EDT
According to the core backtrace, I'm having the same problem, 64bit as well.

I can reproduce this by going to the SQL Editor and inputting the first word of a valid query (SELECT, UPDATE,...). In my case it happens every time.

If I start with an invalid word, for instance "asd", I can type the whole query without crashing and then delete the "asd" and execute the query. If I edit the query after deleting the "asd", it crashes.
Comment 7 Remi Collet 2012-08-29 06:38:54 EDT

*** This bug has been marked as a duplicate of bug 851283 ***

Note You need to log in before you can comment on or make changes to this bug.