Bug 851283 - [abrt] mysql-workbench-5.2.42-1.fc17: MySQL55TreeWalker::get_next: Process /usr/lib64/mysql-workbench/mysql-workbench-bin was killed by signal 11 (SIGSEGV)
[abrt] mysql-workbench-5.2.42-1.fc17: MySQL55TreeWalker::get_next: Process /u...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql-workbench (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
abrt_hash:1726abff6891aec0a73eeed76db...
:
: 850897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 12:46 EDT by Dominique Werder
Modified: 2013-05-24 08:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 07:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.51 KB, text/plain)
2012-08-23 12:47 EDT, Dominique Werder
no flags Details
File: maps (72.58 KB, text/plain)
2012-08-23 12:47 EDT, Dominique Werder
no flags Details
File: dso_list (15.40 KB, text/plain)
2012-08-23 12:47 EDT, Dominique Werder
no flags Details
File: build_ids (5.97 KB, text/plain)
2012-08-23 12:47 EDT, Dominique Werder
no flags Details
MySQL Workbench log during crash (66.89 KB, text/plain)
2012-08-28 13:43 EDT, Massimiliano
no flags Details

  None (edit)
Description Dominique Werder 2012-08-23 12:46:54 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/mysql-workbench/mysql-workbench-bin
crash_function: MySQL55TreeWalker::get_next
executable:     /usr/lib64/mysql-workbench/mysql-workbench-bin
kernel:         3.5.2-3.fc17.x86_64
pid:            9710
pwd:            /home/zeno/Documents
remote_result:  NOTFOUND
time:           Thu 23 Aug 2012 12:43:01 PM EDT
uid:            1000
username:       zeno

backtrace:      Text file, 41484 bytes
build_ids:      Text file, 6109 bytes
dso_list:       Text file, 15765 bytes
maps:           Text file, 74320 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/zeno/1

comment:
:open mysql-workbench
:connect to database
:select rows from a table
:when trying to edit the query in the query window the workbench crashes

core_backtrace:
:a120e61c8e9c92f57f22e508cf51e5cdfe7bd768 0xd8404 MySQL55TreeWalker::get_next(ANTLR3_BASE_TREE_struct*, libmysql55parser.so.0 -
:a120e61c8e9c92f57f22e508cf51e5cdfe7bd768 0xd8689 MySQL55TreeWalker::advance_to_position(int, libmysql55parser.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x3b47e5 Sql_editor::show_auto_completion(bool) libwbpublic.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x3a4e4e Sql_editor::on_sql_check_progress(float, libwbpublic.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x31e32c boost::function2<int, libwbpublic.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x2ca410 boost::signals2::detail::signal1_impl<void, libwbpublic.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x2c104d bec::GRTTask::process_message_m(grt::Message libwbpublic.so.0 -
:09b446ac50d95fa1eb418a1661a02b8068b086ba 0x4607b8 boost::function0<void>::operator()() [exe] -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x2bf43d bec::GRTDispatcher::flush_pending_callbacks() libwbpublic.so.0 -
:6cbe507049691b687e9ea1e45464e98e3b0c7813 0x2d1b9e bec::GRTManager::perform_idle_tasks() libwbpublic.so.0 -
:09b446ac50d95fa1eb418a1661a02b8068b086ba 0x60365a wb::WBContext::flush_idle_tasks() [exe] -
:09b446ac50d95fa1eb418a1661a02b8068b086ba 0x40a0bd sigc::internal::slot_call0<sigc::bind_return_functor<bool, [exe] -
:f3cd3b4e0a6c31e9af1598f478198ab0f52b6ca9 0x49502 - libglibmm-2.4.so.1 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14ac57 gtk_main libgtk-x11-2.0.so.0 -
:09b446ac50d95fa1eb418a1661a02b8068b086ba 0x400783 main [exe] -

environ:
:LD_PRELOAD=/$LIB/libSegFault.so
:SEGFAULT_OUTPUT_NAME=/tmp/segv_output.sfMOcL
:SEGFAULT_USE_ALTSTACK=1
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SSH_AGENT_PID=957
:KDE_MULTIHEAD=false
:HOSTNAME=cara.redomega.org
:DM_CONTROL=/var/run/xdmctl
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:DESKTOP_STARTUP_ID=cara.redomega.org;1345740167;50177;1128_TIME3054130
:HISTSIZE=1000
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/zeno/.gtkrc-2.0:/home/zeno/.gtkrc-2.0-kde4:/home/zeno/.kde/share/config/gtkrc-2.0
:GS_LIB=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/zeno/.gtkrc:/home/zeno/.kde/share/config/gtkrc
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=zeno
:LD_LIBRARY_PATH=/usr/lib64/mysql-workbench
:SSH_AUTH_SOCK=/tmp/ssh-NYNBMESYJ915/agent.915
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1085,unix/unix:/tmp/.ICE-unix/1085
:MAIL=/var/spool/mail/zeno
:DESKTOP_SESSION=default
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/zeno/bin:/usr/share/mysql-workbench/python
:PWD=/home/zeno/Documents
:KDE_SESSION_UID=1000
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:MWB_PLUGIN_DIR=/usr/lib64/mysql-workbench/plugins
:'MYSQL_UTILITIES_COMMANDS=mysqlprocgrep mysqlreplicate mysqlrplcheck mysqlfailover mysqldiskusage mysqldiff mysqlrplshow mysqlrpladmin mysqlindexcheck mysqlserverclone mysqldbimport mysqldbexport mysqldbcopy mysqldbcompare mysqlmetagrep mysqlserverinfo mysqluserclone'
:KDEDIRS=/usr
:MWB_DATA_DIR=/usr/share/mysql-workbench
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=4
:XDG_SEAT=seat0
:HOME=/home/zeno
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:DBC_DRIVER_PATH=/usr/lib64/mysql-workbench
:LOGNAME=zeno
:PYTHONPATH=/usr/share/mysql-workbench/python
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-JiZTaIer4T,guid=94ea4de84d0d988c945a0ea90000001c
:MWB_MODULE_DIR=/usr/lib64/mysql-workbench/modules
:MWB_LIBRARY_DIR=/usr/share/mysql-workbench/libraries
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/zeno
:DISPLAY=:0
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins:/home/zeno/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/
:XAUTHORITY=/tmp/kde-zeno/xauth-1000-_0
:_=/usr/lib64/mysql-workbench/mysql-workbench-bin

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31460                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31460                31460                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[18159]
:pos:	0
:flags:	00
:1:/home/zeno/.xsession-errors
:pos:	243085
:flags:	0100001
:2:/home/zeno/.xsession-errors
:pos:	243085
:flags:	0100001
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[326235]
:pos:	0
:flags:	02000000
:5:pipe:[326235]
:pos:	0
:flags:	02000001
:6:socket:[326236]
:pos:	0
:flags:	02004002
:7:/tmp/mysql-workbench.zeno/9575a100-ed41-11e1-bbd6-001a4d4b8a5d.db
:pos:	7168
:flags:	02100002
:8:/tmp/mysql-workbench.zeno/957667b6-ed41-11e1-bbd6-001a4d4b8a5d.db
:pos:	7168
:flags:	02100002
:9:anon_inode:inotify
:pos:	0
:flags:	02004000
:10:/dev/urandom
:pos:	0
:flags:	02100000
:11:/tmp/mysql-workbench.zeno/957715a8-ed41-11e1-bbd6-001a4d4b8a5d.db
:pos:	7168
:flags:	02100002
:12:/tmp/mysql-workbench.zeno/9577c78c-ed41-11e1-bbd6-001a4d4b8a5d.db
:pos:	7168
:flags:	02100002
:13:/usr/share/mysql-workbench/sshtunnel.py
:pos:	16071
:flags:	0100000
:14:socket:[329263]
:pos:	0
:flags:	02
:15:socket:[328495]
:pos:	0
:flags:	02
:16:/home/zeno/.mysql/workbench/cache/dhnet.cache
:pos:	5120
:flags:	02100002
:17:/tmp/segv_output.sfMOcL
:pos:	77896
:flags:	0100001

var_log_messages:
:Aug 23 09:00:49 cara abrt[4400]: Saved core dump of pid 2169 (/usr/bin/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-09:00:47-2169 (88219648 bytes)
:Aug 23 10:50:30 cara abrt[2815]: Saved core dump of pid 2779 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-10:50:29-2779 (107819008 bytes)
:Aug 23 10:51:00 cara abrt[5035]: Saved core dump of pid 4986 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-10:50:59-4986 (116719616 bytes)
:Aug 23 10:52:37 cara abrt[7336]: Saved core dump of pid 7297 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-10:52:35-7297 (142356480 bytes)
:Aug 23 10:57:01 cara abrt[9706]: Saved core dump of pid 9671 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-10:57:00-9671 (106045440 bytes)
:Aug 23 10:59:01 cara abrt[11981]: Saved core dump of pid 11939 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-10:58:59-11939 (115253248 bytes)
:Aug 23 11:19:36 cara abrt[14391]: Saved core dump of pid 14356 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-11:19:35-14356 (106033152 bytes)
:Aug 23 11:34:44 cara abrt[1532]: Saved core dump of pid 1496 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-11:34:43-1496 (106082304 bytes)
:Aug 23 11:53:44 cara abrt[1760]: Saved core dump of pid 1715 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-11:53:43-1715 (106110976 bytes)
:Aug 23 12:13:04 cara abrt[4474]: Saved core dump of pid 4430 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-12:13:03-4430 (149532672 bytes)
:Aug 23 12:15:08 cara abrt[6773]: Saved core dump of pid 6735 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-12:15:07-6735 (134176768 bytes)
:Aug 23 12:43:02 cara abrt[9743]: Saved core dump of pid 9710 (/usr/lib64/mysql-workbench/mysql-workbench-bin) to /var/spool/abrt/ccpp-2012-08-23-12:43:01-9710 (88363008 bytes)
Comment 1 Dominique Werder 2012-08-23 12:47:00 EDT
Created attachment 606652 [details]
File: backtrace
Comment 2 Dominique Werder 2012-08-23 12:47:02 EDT
Created attachment 606653 [details]
File: maps
Comment 3 Dominique Werder 2012-08-23 12:47:03 EDT
Created attachment 606654 [details]
File: dso_list
Comment 4 Dominique Werder 2012-08-23 12:47:06 EDT
Created attachment 606655 [details]
File: build_ids
Comment 5 Alan Schmidt 2012-08-23 13:28:28 EDT
Selected a schema, entered a query, pressed the lightning bolt.

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Mark Rooks 2012-08-24 04:36:30 EDT
I was in the middle of saving a query file when the app crashed.

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Aditya Mukhopadhyay 2012-08-24 05:10:44 EDT
Crashes soon after opening a connection to localhost

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Ralf Oltmanns 2012-08-24 08:10:16 EDT
Entered a query into the SQL query window when workbench crashed

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 István Tóth 2012-08-24 08:46:06 EDT
Same here. 
Downgrading to mysql-workbench-5.2.38-2.fc17.x86_64 fixes the problem.
Comment 10 Alan Schmidt 2012-08-24 12:23:51 EDT
The newest version from Koji that fixes the problem (for me) is mysql-workbench-5.2.40-1.fc17.x86_64.rpm.

mysql-workbench-5.2.41-2.fc17.x86_64.rpm wasn't old enough (for me).
Comment 11 Giovanni Sosa 2012-08-24 18:34:03 EDT
1. I open mysql workbench
2. I connect to a local database 'localhost'
3. I openend the editor start typing select replace...
4. It crashed Down

Another scenario

same 1 to 3 steps
4. Alt tab to another program
5. It crashed

I think it maybe is the autocompletation feature introduced in the 5.2.42 version. It crashes in Other OS too.


backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Reinier Balt 2012-08-26 10:30:05 EDT
started to type a sql query

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Remi Collet 2012-08-27 02:36:54 EDT
Workaround, from Preferences / SQL Editor : uncheck "Enable Code completion in Editors"
Comment 14 Giovanni Sosa 2012-08-27 11:37:00 EDT
The new autocompletation feature is unstable, so unchecking works no need to downgrade, Thanks (In reply to comment #13)
> Workaround, from Preferences / SQL Editor : uncheck "Enable Code completion
> in Editors"
Comment 15 Alan Schmidt 2012-08-27 15:42:45 EDT
Should this therefore be reported upstream?

I searched http://bugs.mysql.com/ and I found absence of proof that it had been reported (which of course is not proof of absence).

I'm also not entirely certain whether I need to use Oracle's binary in order to log an error in the first place (in which case I'd need to downgrade to F15, I guess), so I balked.
Comment 16 k 2012-08-27 19:02:12 EDT
Typing a query in SQL editor and it just crashed unexpectedly

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Remi Collet 2012-08-28 03:18:38 EDT
I can reproduce this bug on fedora 17.

I cannot reproduce on fedora 16, so I think this is specific to fedora, when system antlr used instead of bundled version.

I plan a quick update with auto completion totally disabled.

Should be really soon in updates-testing repository.
Comment 18 Sascha Schmidt 2012-08-28 04:57:21 EDT
open workbench
open remote database server
select database
select table
send select all statement to sql editor
edit sql statement
crash


backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 Fedora Update System 2012-08-28 05:11:36 EDT
mysql-workbench-5.2.42-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mysql-workbench-5.2.42-2.fc17
Comment 20 Fedora Update System 2012-08-28 05:12:01 EDT
mysql-workbench-5.2.42-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mysql-workbench-5.2.42-2.fc18
Comment 21 Massimiliano 2012-08-28 13:43:01 EDT
Created attachment 607668 [details]
MySQL Workbench log during crash

MySQL Workbench crashes while writing SQL if code completion is enabled in SQL editor.

Version-Release number:
$ rpm -q mysql-workbench
mysql-workbench-5.2.42-1.fc17.x86_64

Steps to Reproduce:
1. Open mysql-workbench
2. Connect to a database
3. Enable "Preferences" > "SQL editor" > "Enable code completion in Editors"
4. Start typing sql code into a sql tab
  
Actual results:
MySQL Workbench crashes and produce attached log (segfault.txt) from .xsession-errors

Expected results:
No crash, code completion works.

Additional info:
When code completion is disabled you can edit SQL code.
Comment 22 Fedora Update System 2012-08-28 14:15:50 EDT
Package mysql-workbench-5.2.42-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mysql-workbench-5.2.42-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12853/mysql-workbench-5.2.42-2.fc18
then log in and leave karma (feedback).
Comment 23 Colin Gillespie 2012-08-29 06:25:13 EDT
When I start typing a query into a sql tab within 5 seconds mysql workbench crashes.

backtrace_rating: 4
Package: mysql-workbench-5.2.42-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 24 Remi Collet 2012-08-29 06:38:54 EDT
*** Bug 850897 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2012-09-07 07:32:03 EDT
mysql-workbench-5.2.42-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2012-09-17 18:52:18 EDT
mysql-workbench-5.2.42-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 akojima 2013-05-24 08:24:14 EDT
This is a bug in the Antlr runtime shipped in Fedora. See bug #966973 for a fix.

Note You need to log in before you can comment on or make changes to this bug.