Bug 850925 - SELinux is preventing /usr/sbin/abrt-dbus from 'read' accesses on the directory /home/mikhail/.abrt/spool.
SELinux is preventing /usr/sbin/abrt-dbus from 'read' accesses on the directo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3ebc82d5e5c9cef4c4f3eaf737e...
:
: 850924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 14:56 EDT by Mikhail
Modified: 2012-08-22 15:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 15:35:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-08-22 14:56:21 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.2-1.fc17.i686.PAE
time:           Чт. 23 авг. 2012 00:56:09

description:
:SELinux is preventing /usr/sbin/abrt-dbus from 'read' accesses on the directory /home/mikhail/.abrt/spool.
:
:*****  Plugin restorecon (82.4 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/mikhail/.abrt/spool default label should be user_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/mikhail/.abrt/spool
:
:*****  Plugin file (7.05 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin file (7.05 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin catchall_labels (4.59 confidence) suggests  ********************
:
:If you want to allow abrt-dbus to have read access on the spool directory
:Then you need to change the label on /home/mikhail/.abrt/spool
:Do
:# semanage fcontext -a -t FILE_TYPE '/home/mikhail/.abrt/spool'
:where FILE_TYPE is one of the following: sysctl_crypto_t, rpm_var_cache_t, abrt_var_cache_t, var_spool_t, modules_object_t, abrt_etc_t, abrt_tmp_t, var_log_t, var_lib_t, var_run_t, configfile, domain, abrt_var_run_t, abrt_var_log_t, device_t, rpm_var_lib_t, rpm_var_run_t, etc_t, abrt_t, lib_t, inotifyfs_t, device_t, devpts_t, root_t, public_content_t, usr_t, net_conf_t, sysctl_kernel_t, httpd_modules_t, public_content_rw_t, device_t, locale_t, etc_t, proc_t, dbusd_etc_t, textrel_shlib_t, etc_t, abrt_t, bin_t, cert_t, nfs_t, lib_t, sysfs_t, mnt_t, tmp_t, usr_t, var_t, etc_t, cert_t, var_run_t, nscd_var_run_t, root_t. 
:Then execute: 
:restorecon -v '/home/mikhail/.abrt/spool'
:
:
:*****  Plugin catchall (1.31 confidence) suggests  ***************************
:
:If you believe that abrt-dbus should be allowed read access on the spool directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:file_t:s0
:Target Objects                /home/mikhail/.abrt/spool [ dir ]
:Source                        abrt-dbus
:Source Path                   /usr/sbin/abrt-dbus
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           abrt-dbus-2.0.10-4.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-1.fc17.i686.PAE #1 SMP Wed
:                              Aug 15 16:30:14 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-08-23 00:55:56 YEKT
:Last Seen                     2012-08-23 00:55:56 YEKT
:Local ID                      62cf16d6-7335-4001-8244-a7034be87b81
:
:Raw Audit Messages
:type=AVC msg=audit(1345661756.225:60): avc:  denied  { read } for  pid=1329 comm="abrt-dbus" name="spool" dev="sdb" ino=162792919 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1345661756.225:60): arch=i386 syscall=openat success=no exit=EACCES a0=ffffff9c a1=8e3f2e0 a2=98800 a3=0 items=0 ppid=1 pid=1329 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
:
:Hash: abrt-dbus,abrt_t,file_t,dir,read
:
:audit2allow
:
:#============= abrt_t ==============
:allow abrt_t file_t:dir read;
:
:audit2allow -R
:
:#============= abrt_t ==============
:allow abrt_t file_t:dir read;
:
Comment 1 Miroslav Grepl 2012-08-22 15:35:07 EDT
Your homedir is mislabeled.

# restorecon -R -v /home/mikhail


will fix it.
Comment 2 Miroslav Grepl 2012-08-22 15:35:19 EDT
*** Bug 850924 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.