Bug 850939 - "Process /usr/bin/mandb was killed by signal 6 (SIGABRT)"
"Process /usr/bin/mandb was killed by signal 6 (SIGABRT)"
Status: CLOSED DUPLICATE of bug 855632
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 16:08 EDT by Sergio
Modified: 2012-10-18 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 15:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergio 2012-08-22 16:08:15 EDT
Description of problem:
ABRT has been reporting this almost every day recently.
I can't send a bug report through it as it says the backtrace is unusable (the Smolt profile collecting fails with signal 9 too which 'smells' as Smolt bug).

Version-Release number of selected component (if applicable): 2.6.0.2-8.fc17


How reproducible: I don't know the reason. At first I thought it might be if I suspended when mandb was running but I see that it happens independent of that.
For instance today /var/log/cron says
.
Aug 22 06:46:01 f17 anacron[1122]: Job `cron.daily' started
Aug 22 06:46:01 f17 run-parts(/etc/cron.daily)[1228]: starting cups
Aug 22 06:46:01 f17 run-parts(/etc/cron.daily)[1236]: finished cups
Aug 22 06:46:01 f17 run-parts(/etc/cron.daily)[1228]: starting download-upgrades
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1251]: finished download-upgrades
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1228]: starting exim-tidydb
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1258]: finished exim-tidydb
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1228]: starting google-chrome
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1295]: finished google-chrome
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1228]: starting google-talkplugin
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1330]: finished google-talkplugin
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1228]: starting logrotate
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1337]: finished logrotate
Aug 22 06:46:22 f17 run-parts(/etc/cron.daily)[1228]: starting man-db.cron
Aug 22 06:46:26 f17 run-parts(/etc/cron.daily)[1661]: finished man-db.cron
Aug 22 06:46:26 f17 run-parts(/etc/cron.daily)[1228]: starting mlocate.cron
Aug 22 06:46:55 f17 run-parts(/etc/cron.daily)[1698]: finished mlocate.cron
Aug 22 06:46:55 f17 run-parts(/etc/cron.daily)[1228]: starting tmpwatch
Aug 22 06:46:56 f17 run-parts(/etc/cron.daily)[1724]: finished tmpwatch
Aug 22 06:46:56 f17 anacron[1122]: Job `cron.daily' terminated (mailing output)
Aug 22 06:46:57 f17 anacron[1122]: Normal exit (1 job run)
.

See that man-db.cron took only 4 seconds. When it works properly it takes more time, maybe?

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sergio 2012-08-22 16:11:16 EDT
I deleted the ABRT entry, but if anyone likes then next time I copy whatever ABRT has to say about it.
Comment 2 Peter Schiffer 2012-08-23 05:28:53 EDT
Please do, maybe there will be something useful. From this information it is really hard to find the cause of this error.

Thanks,

peter
Comment 3 Sergio 2012-08-24 09:27:00 EDT
I found there was some info in ~/.abrt
http://fpaste.org/4Btu/

Above was from 22 Aug, below was from 20 Aug:
http://fpaste.org/DOzO/
Comment 4 Peter Schiffer 2012-08-24 09:36:05 EDT
Thanks. Could you upload here /var/spool/abrt/ccpp-2012-08-22-06:46:26-1345 coredump (if you still have it)?

peter
Comment 5 Sergio 2012-08-24 11:10:30 EDT
(In reply to comment #4)
> Thanks. Could you upload here /var/spool/abrt/ccpp-2012-08-22-06:46:26-1345
> coredump (if you still have it)?
> 
> peter

Unfortunately that was deleted (actually I clicked to delete in abrt-gui, then polkit's authentication password box came up, I thought better, cancelled but it deleted all the same).

Today (24) it didn't give any error (and yesterday I didn't use the PC).
Comment 6 Peter Schiffer 2012-08-24 11:16:57 EDT
OK. If you see the error again, please upload the coredump. That would be a great help.

Thanks,

peter
Comment 7 Sergio 2012-09-09 09:01:40 EDT
I reported via abrt-cli at https://bugzilla.redhat.com/show_bug.cgi?id=855632
(abrt-gui is very buggy here)
Comment 8 redhat 2012-09-14 01:33:49 EDT
The same happens to may every day:

/etc/cron.daily/man-db.cron:

*** glibc detected *** mandb: free(): invalid pointer: 0xb77ad923 ***
======= Backtrace: =========
/lib/libc.so.6(+0x758e9)[0xb76218e9]
mandb[0x80548da]
mandb[0x8054df5]
mandb[0x8051723]
mandb[0x804a765]
/lib/libc.so.6(__libc_start_main+0xf5)[0xb75c5635]
mandb[0x804ab19]
======= Memory map: ========
08048000-08063000 r-xp 00000000 fd:00 401623     /usr/bin/mandb
08063000-08064000 r--p 0001a000 fd:00 401623     /usr/bin/mandb
08064000-08065000 rw-p 0001b000 fd:00 401623     /usr/bin/mandb
08065000-08067000 rw-p 00000000 00:00 0
08b40000-08d4e000 rw-p 00000000 00:00 0          [heap]
b6e80000-b6e9c000 r-xp 00000000 fd:00 394190     /usr/lib/libgcc_s-4.7.0-20120507.so.1
b6e9c000-b6e9d000 rw-p 0001b000 fd:00 394190     /usr/lib/libgcc_s-4.7.0-20120507.so.1
b6eaa000-b6eea000 r--p 00440000 fd:00 403119     /usr/lib/locale/locale-archive
b6eea000-b701b000 r--p 00195000 fd:00 403119     /usr/lib/locale/locale-archive
b701b000-b721b000 r--p 00000000 fd:00 403119     /usr/lib/locale/locale-archive
b721b000-b73e3000 rw-s 00000000 fd:00 1705651    /var/cache/man/index.db (deleted)
b73e3000-b75ab000 rw-s 00000000 fd:00 1709363    /var/cache/man/index.db
b75ab000-b75ac000 rw-p 00000000 00:00 0
b75ac000-b7757000 r-xp 00000000 fd:00 394235     /usr/lib/libc-2.15.so
b7757000-b7758000 ---p 001ab000 fd:00 394235     /usr/lib/libc-2.15.so
b7758000-b775a000 r--p 001ab000 fd:00 394235     /usr/lib/libc-2.15.so
b775a000-b775b000 rw-p 001ad000 fd:00 394235     /usr/lib/libc-2.15.so
b775b000-b775e000 rw-p 00000000 00:00 0
b775e000-b7769000 r-xp 00000000 fd:00 401611     /usr/lib/libpipeline.so.1.2.0
b7769000-b776a000 rw-p 0000b000 fd:00 401611     /usr/lib/libpipeline.so.1.2.0
b776a000-b776b000 rw-p 00000000 00:00 0
b776b000-b7772000 r-xp 00000000 fd:00 395194     /usr/lib/libgdbm.so.4.0.0
b7772000-b7773000 r--p 00006000 fd:00 395194     /usr/lib/libgdbm.so.4.0.0
b7773000-b7774000 rw-p 00007000 fd:00 395194     /usr/lib/libgdbm.so.4.0.0
b7774000-b7789000 r-xp 00000000 fd:00 394392     /usr/lib/libz.so.1.2.5
b7789000-b778a000 rw-p 00014000 fd:00 394392     /usr/lib/libz.so.1.2.5
b7795000-b7796000 rw-p 00000000 00:00 0
b7796000-b7797000 r--p 01315000 fd:00 403119     /usr/lib/locale/locale-archive
b7797000-b77b2000 r-xp 00000000 fd:00 401626     /usr/lib/man-db/libman-2.6.0.2.so
b77b2000-b77b3000 r--p 0001a000 fd:00 401626     /usr/lib/man-db/libman-2.6.0.2.so
b77b3000-b77b4000 rw-p 0001b000 fd:00 401626     /usr/lib/man-db/libman-2.6.0.2.so
b77b4000-b77b5000 rw-p 00000000 00:00 0
b77b5000-b77ba000 r-xp 00000000 fd:00 401629     /usr/lib/man-db/libmandb-2.6.0.2.so
b77ba000-b77bb000 r--p 00004000 fd:00 401629     /usr/lib/man-db/libmandb-2.6.0.2.so
b77bb000-b77bc000 rw-p 00005000 fd:00 401629     /usr/lib/man-db/libmandb-2.6.0.2.so
b77bc000-b77bd000 rw-p 00000000 00:00 0
b77bd000-b77be000 r-xp 00000000 00:00 0          [vdso]
b77be000-b77dd000 r-xp 00000000 fd:00 403090     /usr/lib/ld-2.15.so
b77dd000-b77de000 r--p 0001e000 fd:00 403090     /usr/lib/ld-2.15.so
b77de000-b77df000 rw-p 0001f000 fd:00 403090     /usr/lib/ld-2.15.so
bff0d000-bff2e000 rw-p 00000000 00:00 0          [stack]
/etc/cron.daily/man-db.cron: line 25: 16846 Aborted                 mandb $OPTS
Comment 9 Peter Schiffer 2012-10-18 15:25:28 EDT

*** This bug has been marked as a duplicate of bug 855632 ***

Note You need to log in before you can comment on or make changes to this bug.