Bug 855632 - [abrt] man-db-2.6.0.2-8.fc17: check_for_stray: Process /usr/bin/mandb was killed by signal 6 (SIGABRT)
[abrt] man-db-2.6.0.2-8.fc17: check_for_stray: Process /usr/bin/mandb was kil...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
abrt_hash:bd1ce11f767eee63b985a23147e...
:
: 850939 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 08:52 EDT by Sergio
Modified: 2012-12-20 11:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:15:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (596 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: environ (158 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: backtrace (6.23 KB, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: cgroup (127 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: maps (2.52 KB, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: dso_list (815 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: build_ids (369 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: var_log_messages (142 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details
File: open_fds (242 bytes, text/plain)
2012-09-09 08:52 EDT, Sergio
no flags Details

  None (edit)
Description Sergio 2012-09-09 08:52:20 EDT
Description of problem:
This is a cron.daily job. It fails 'silently' as abrt seems to be rather buggy here, specially when it's a root job.

Version-Release number of selected component:
man-db-2.6.0.2-8.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        mandb -q
crash_function: check_for_stray
kernel:         3.5.2-3.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (4 frames)
: #6 check_for_stray at straycats.c
: #7 open_catdir at straycats.c
: #8 straycats at straycats.c
: #9 process_manpath at mandb.c
Comment 1 Sergio 2012-09-09 08:52:23 EDT
Created attachment 611224 [details]
File: core_backtrace
Comment 2 Sergio 2012-09-09 08:52:25 EDT
Created attachment 611225 [details]
File: environ
Comment 3 Sergio 2012-09-09 08:52:27 EDT
Created attachment 611226 [details]
File: limits
Comment 4 Sergio 2012-09-09 08:52:29 EDT
Created attachment 611227 [details]
File: backtrace
Comment 5 Sergio 2012-09-09 08:52:31 EDT
Created attachment 611228 [details]
File: cgroup
Comment 6 Sergio 2012-09-09 08:52:33 EDT
Created attachment 611229 [details]
File: maps
Comment 7 Sergio 2012-09-09 08:52:35 EDT
Created attachment 611230 [details]
File: dso_list
Comment 8 Sergio 2012-09-09 08:52:37 EDT
Created attachment 611231 [details]
File: build_ids
Comment 9 Sergio 2012-09-09 08:52:39 EDT
Created attachment 611232 [details]
File: var_log_messages
Comment 10 Sergio 2012-09-09 08:52:41 EDT
Created attachment 611233 [details]
File: open_fds
Comment 11 Sergio 2012-09-09 08:58:11 EDT
Same as Sept 2nd report. This is a cron.daily job that sometimes fails.

backtrace_rating: 4
Package: man-db-2.6.0.2-8.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Sergio 2012-09-10 06:14:15 EDT
Sending it in case it has any news (I doubt).

backtrace_rating: 4
Package: man-db-2.6.0.2-8.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Peter Schiffer 2012-10-18 15:25:28 EDT
*** Bug 850939 has been marked as a duplicate of this bug. ***
Comment 14 Peter Schiffer 2012-10-24 12:22:19 EDT
fixed in rawhide:
man-db-2.6.3-1.fc19
http://koji.fedoraproject.org/koji/buildinfo?buildID=362104
Comment 15 Fedora Update System 2012-10-24 12:46:47 EDT
man-db-2.6.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/man-db-2.6.3-1.fc18
Comment 16 Fedora Update System 2012-10-24 13:10:47 EDT
man-db-2.6.0.2-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-9.fc17
Comment 17 Fedora Update System 2012-10-24 19:57:13 EDT
Package man-db-2.6.0.2-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.0.2-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16849/man-db-2.6.0.2-9.fc17
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-11-06 04:59:45 EST
man-db-2.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/man-db-2.6.3-2.fc18
Comment 19 Fedora Update System 2012-12-20 11:15:12 EST
man-db-2.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.