Bug 851 - usernet get confused as to ppp connection state
usernet get confused as to ppp connection state
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: usernet (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 1156 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-16 11:26 EST by kenc
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-28 15:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kenc 1999-01-16 11:26:20 EST
Using usernet to allow user to bring up and take down a ppp
connection.  Works most of the time.  But occasionally gets
very confused as to whether the link is up or not.  I can
duplicate problem by clicking on the ppp0 button while
status is yellow, or by double clicking it in rapid
succession.  It appears to not realize that the link is in
the process of comming up and launches a second pppd demon
to bring the link up again, which gets  stuck because the
first pppd demon has the modem device locked.  Thereafter
every attempt to use usernet to change the ppp0 link status
launches yet another pppd demon.  Only way out of mess is to
logon as root user and kill all of the pppd and if-up
processes.
Comment 1 David Lawrence 1999-01-19 15:33:59 EST
This has been observed to be true on a machine in the test lab. The
problem actually lies with more than usernet itself, more to do with
the way initscripts handles ppp connections. It will possibly be fixed
at a later date.
Comment 2 David Lawrence 1999-04-01 14:56:59 EST
*** Bug 1156 has been marked as a duplicate of this bug. ***

Clicking on the ppp0 widget at the wrong time (when PPP is
coming up or going down, or the ISP isn't responding), or
clicking on the color widget, can put usernet into a lost
state where it no longer brings PPP up or brings it down, or
re-initializes the modem.  Colors may change, but modem
activity does not.  Killing and restarting usernet doesn't
clear this.  Tried killing X Windows and logging out, then
coming back in.  That didn't help.  Re-booting the host
cleared the problem.
Comment 3 Jay Turner 1999-06-29 13:22:59 EDT
Michael, what is the status of this?  Can we resolve this?
Comment 4 Michael K. Johnson 1999-08-28 15:08:59 EDT
Fixing this requires a new version of ppp and changes to initscripts
that depend on the new version of ppp.

The new version of ppp and initscripts are in the RawHide tree.
They seem to be pretty reliable in limited testing; it sometimes
takes a while to take the interface down because chat/wvdial take
a while to stop when signaled, but the new code seems otherwise
reliable.  Unfortunately, we can't really fix it adequately in
older releases.  :-(

So this should be fixed now in RawHide, and the next official
release of Red Hat Linux should have it fixed as well.

Note You need to log in before you can comment on or make changes to this bug.