This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 851288 - Failed to load resource composite data error when refreshing Inventory page (Unavailable Servers, Servers, etc)
Failed to load resource composite data error when refreshing Inventory page (...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.0,JON 3.1.1,JON 3.1.2
All All
low Severity high
: Alpha-x
: JON 3.2.0
Assigned To: Jirka Kremser
Mike Foley
:
: 857032 (view as bug list)
Depends On: 773626
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 13:15 EDT by Larry O'Leary
Modified: 2014-01-02 15:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 773626
Environment:
Last Closed: 2014-01-02 15:35:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 189053 None None None 2012-08-23 13:51:23 EDT

  None (edit)
Description Larry O'Leary 2012-08-23 13:15:14 EDT
+++ This bug was initially created as a clone of Bug #773626 +++

java.lang.RuntimeException:[1326373428381] javax.ejb.EJBException:java.lang.IllegalArgumentException: PageList was passed an empty collection but 'totalSize' was 1, PageControl[firstRow=42, size=50] -> java.lang.IllegalArgumentException:PageList was passed an empty collection but 'totalSize' was 1, PageControl[firstRow=42, size=50]
--- STACK TRACE FOLLOWS ---
[1326373428381] javax.ejb.EJBException:java.lang.IllegalArgumentException: PageList was passed an empty collection but 'totalSize' was 1, PageControl[firstRow=42, size=50] -> java.lang.IllegalArgumentException:PageList was passed an empty collection but 'totalSize' was 1, PageControl[firstRow=42, size=50]
   at Unknown.java_lang_RuntimeException_$RuntimeException__Ljava_lang_RuntimeException_2Ljava_lang_RuntimeException_2(Unknown source:0)
   at Unknown.com_google_gwt_user_client_rpc_core_java_lang_RuntimeException_1FieldSerializer_instantiate__Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_RuntimeException_2(Unknown source:0)
   at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
   at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
   at Unknown.com_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_$readObject__Lcom_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_2Ljava_lang_Object_2(Unknown source:0)
   at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
   at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknow

--- Additional comment from claprun@redhat.com on 2012-01-12 08:12:30 EST ---

Actually, the same happens also if I just click on unavailable server from the resource list on the left…

--- Additional comment from lkrejci@redhat.com on 2012-01-18 06:44:10 EST ---

I tried clicking on the "Unavailable servers" link in the main Inventory tab with both a server unavailable and no servers unavailable and I could not reproduce this. I also tried to click the "Refresh" button on that page and got no exceptions.

Are those correct repro-steps?

Btw. I tried this on RHQ-4.3.0-SNAPSHOT build 5b4ab4a.

--- Additional comment from lkrejci@redhat.com on 2012-01-18 10:17:55 EST ---

could not reproduce in build 81533f2 (the latest available at the time of writing this comment) either.

--- Additional comment from ian.springer@redhat.com on 2012-02-14 21:45:17 EST ---

This sounds very similar to https://bugzilla.redhat.com/show_bug.cgi?id=720490, which was fixed back on 10/14/11, but it's possible the fix didn't make it into RHQ 4.2, which was released on 10/31/11.

--- Additional comment from loleary@redhat.com on 2012-08-23 13:07:04 EDT ---

This issue can be seen in RHQ 4.4.0. I can see it in the Inventory -> Servers page. What I have come to realize and accept is that the problem will only appear when certain circumstances allow. Specifically:

- screen resolution
- number of resources in the list
- font size
- resource names
- width of browser window

I am able to reproduce the issue with 17 servers in inventory combined with: 
    * zooming in from the browser
    * or reducing the width of my web browser
    * or increasing the default font size
    * or changing default fonts
    * or changing screen resolutions 
    * or changing the width of the Ancestor or Description column to their minimum

In my case, I go to the server resources page and scroll to the bottom of the list and then click the Refresh button.

Depending on my zoom level, resolution, font size, browser window width, etch, the error message will change:

	

--- STACK TRACE FOLLOWS ---
[1345752450732] javax.ejb.EJBException:java.lang.IllegalArgumentException: PageList was passed an empty collection but 'totalSize' was 17, PageControl[firstRow=24, size=50] -> java.lang.IllegalArgumentException:PageList was passed an empty collection but 'totalSize' was 17, PageControl[firstRow=24, size=50]
   at Unknown.java_lang_RuntimeException_RuntimeException__V(Unknown Source)
   at Unknown.com_google_gwt_user_client_rpc_core_java_lang_RuntimeException_1FieldSerializer_instantiate__Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_RuntimeException_2(Unknown Source)
   at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.com_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_$readObject__Lcom_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown Source)
   at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown Source)
   at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown Source)
   at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown Source)
   at Unknown.anonymous(Unknown Source)
   at Unknown.com_google_gwt_core_client_impl_Impl_apply__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.anonymous(Unknown Source)
   at Unknown.anonymous(Unknown Source)
   
   
   
Specifically, PageControl[firstRow=24, size=50] will change. Like PageControl[firstRow=19, size=49].




What appears to be happening here is that the row height might be to blame and is causing the dataset paging to be beyond the initial rendering of the control when the default row height is used.

I have attached a couple of screen-shots that show what my Inventory -> Servers page looks like in a working state vs. non-working state after I reduced the column width of the Ancestor and Description columns.

--- Additional comment from loleary@redhat.com on 2012-08-23 13:08:19 EDT ---

Created attachment 606658 [details]
Inventory -> Servers Screen Shot - No Error

--- Additional comment from loleary@redhat.com on 2012-08-23 13:09:02 EDT ---

Created attachment 606659 [details]
Inventory -> Servers Screen Shot after column resize - Error
Comment 1 Jirka Kremser 2012-08-24 09:59:11 EDT
I wasn't able to reproduce this bug at all. Then Larry suggested following repro steps:

1) Open Inventory -> Resources -> Servers
2) Increase the font in browser (in FF I use second largest)
3) scroll down the table
4) hit refresh

Firstly, I wasn't able to reproduce it with those steps either, but if I change the constant Table.DATA_PAGE_SIZE from 50 to 10, then it is possible to reproduce it with Larry's steps.

Looks like the Table component on the client side firstly wrongly set the criteria i.e. firstRow=25 even there are only, say, 18 resources, then the exception is thrown at ResourceManagetBean, goes through the ResourceGWTServiceImpl back to the client (WITHOUT any server side logging, since it is a runtime exception) and ends up in the message center. 

Wrapping of lines when using large fonts may cause this issue, because the criteria for paging purposes are generated by SmartGWT when scrolling down the ListGrid.
Comment 2 mark yarborough 2012-11-06 15:05:12 EST
Per 3.1.2 triage with loleary, mfoley, ccrouch, asantos: Okay to move to JON 3.2.
Comment 4 Heiko W. Rupp 2013-08-09 11:45:20 EDT
Jirka,
could you please look at it for 3.2 (rhq 4.10) ?
Comment 5 Larry O'Leary 2013-08-09 11:46:32 EDT
*** Bug 857032 has been marked as a duplicate of this bug. ***
Comment 6 Lukas Krejci 2013-09-02 07:28:17 EDT
I believe this has the same underlying cause as BZ 855674. Pushing to modified so that we can have it tested.
Comment 7 Mike Foley 2013-09-13 18:46:09 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.