Bug 857032 - Server returned FAILURE with no error message during inventory listing
Server returned FAILURE with no error message during inventory listing
Status: CLOSED DUPLICATE of bug 851288
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory (Show other bugs)
JON 3.1.0,JON 3.1.1
Unspecified Linux
unspecified Severity high
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 08:19 EDT by Viliam Rockai
Modified: 2015-08-31 23:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 11:46:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (463.15 KB, text/x-log)
2012-09-13 08:19 EDT, Viliam Rockai
no flags Details
agent.log (115.30 KB, text/x-log)
2012-09-13 08:19 EDT, Viliam Rockai
no flags Details
error screenshot (82.30 KB, image/jpeg)
2012-09-13 11:39 EDT, Viliam Rockai
no flags Details
DEBUG level server.log (2.94 MB, text/x-log)
2012-09-13 11:40 EDT, Viliam Rockai
no flags Details

  None (edit)
Description Viliam Rockai 2012-09-13 08:19:18 EDT
Created attachment 612424 [details]
server.log

I've just run the JON 3.1.1.CR2 with EPP 5.2.2 GA and Gatein Plugin 1.0.1

We used the following artifacts:
* jon-server-3.1.1.CR2.zip
* jon-plugin-pack-epp-3.1.1.CR2
(both from: https://brewweb.devel.redhat.com/buildinfo?buildID=232185)
* EPP 5.2.2 GA / EAP 5.1.2 GA

I've bumped into an issue. The GateIn plugin (1.0.1) seems to we working
all-right, but after importing the server from the Inverntory ->
Discovery queue, i can't access it from Platforms or Servers. I see this
error:
Server returned FAILURE with no error message.

In the message center I can see more info about this error:

Detail :
java.lang.RuntimeException:[1347536194761]
javax.ejb.EJBException:java.lang.IllegalArgumentException: PageList was
passed an empty collection but 'totalSize' was 1,
PageControl[firstRow=25, size=50] ->
java.lang.IllegalArgumentException:PageList was passed an empty
collection but 'totalSize' was 1, PageControl[firstRow=25, size=50]
--- STACK TRACE FOLLOWS ---
[1347536194761]
javax.ejb.EJBException:java.lang.IllegalArgumentException: PageList was
passed an empty collection but 'totalSize' was 1,
PageControl[firstRow=25, size=50] ->
java.lang.IllegalArgumentException:PageList was passed an empty
collection but 'totalSize' was 1, PageControl[firstRow=25, size=50]
    at Unknown.java_lang_RuntimeException_RuntimeException__V(Unknown
Source)
    at
Unknown.com_google_gwt_user_client_rpc_core_java_lang_RuntimeException_1FieldSerializer_instantiate__Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_RuntimeException_2(Unknown
Source)
    at
Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown
Source)
    at
Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown
Source)
    at
Unknown.com_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_$readObject__Lcom_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_2Ljava_lang_Object_2(Unknown
Source)
    at
Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown
Source)
    at
Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown
Source)
    at
Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown
Source)
    at
Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown
Source)


Anyway, I'm able to access the EPP info when I click on Inventory -> All
Resources -> Name of my computer, and plugin seems to be working alright.

I'm able to reproduce this issue even when using EAP 5.2.1 GA instead of EPP 5.2.2 GA. I think this is not related to plugin, but it is a jon-server issue.

On 3.0.1 GA this issue was not present, it seems to be a regression between 3.0.1->3.1.0
Comment 1 Viliam Rockai 2012-09-13 08:19:49 EDT
Created attachment 612425 [details]
agent.log
Comment 2 Mike Foley 2012-09-13 08:36:15 EDT
raising priority.  setting target release to JON 3.1.1 (this breaks the EPP plugin).  

related BZ (same error, but completely different repro steps):

 https://bugzilla.redhat.com/show_bug.cgi?id=855674
Comment 3 Mike Foley 2012-09-13 10:13:35 EDT
100% reproducible from villiam 

<vrockai> for me, it's happening all the time
Comment 4 Mike Foley 2012-09-13 10:14:31 EDT
<mfoley> so is this a blocking issue for EPP plugin?
<vrockai> EPP plugin seem to be ok and there is a workaround
Comment 5 Mike Foley 2012-09-13 10:15:50 EDT
<mfoley> is the workaround listed in the BZ?
<vrockai> should be, let me check
<vrockai> Anyway, I'm able to access the EPP info when I click on Inventory -> All
<vrockai> Resources -> Name of my computer, and plugin seems to be working alright.
<vrockai> it is
Comment 6 Mike Foley 2012-09-13 10:44:45 EDT
discussed with jshaugn and villiam.

summary:  it's an issue.  it's not related to the plugin.  it's related to the UI.  it's not blocking for JON 3.1.1.  troubling that it is so reproducible (100%) for villiam ...and sporadic for others.

as a result ... i am setting the target release to jon 3.1.2
Comment 7 Charles Crouch 2012-09-13 11:26:09 EDT
This seems possibly related:
https://bugzilla.redhat.com/show_bug.cgi?id=808548

Was Villiam testing with a local browser+local server?
Comment 8 Viliam Rockai 2012-09-13 11:38:05 EDT
Steps to reproduce:
1. Clean up DB
2. Download bundles:
(JON server)
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.1.1.CR2/1/maven/org/jboss/on/jon-server/3.1.1.CR2/jon-server-3.1.1.CR2.zip
(JON plugins)
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.1.1.CR2/1/maven/org/jboss/on/jon-plugin-pack-epp/3.1.1.CR2/jon-plugin-pack-epp-3.1.1.CR2.zip
3. Unzip both
4. Copy the contents of plugins into jon-server-3.1.1.CR2/plugins
5. Copy attached jboss-log4j.xml into jon-server-3.1.1.CR2/jbossas/server/default/conf
6. Download and unzip EPP 5.2.2 GA, run it.
7. Run the JON server, install it, access JON interface, login (jon-server-3.1.1.CR2$ sh bin/rhq-server.sh start)
8. Go to administration -> downloads, download current agent jar, install it, run it (rhq-agent$ sh bin/rhq-agent.sh)
9. Go to Inventory -> Discovery Queue, and import the EPP server
10. Click on platforms

I'm also attaching my DEBUG log (according to my attached log4j settings) and the screenshot of error message. It was tested on Chromium 18, FF 14 and FF 10.

Clues: 
- When I open console in chromium (F12) or firebug in FF, I'm unable to reproduce the issue. After I close the console/firebug, the error is present again.
- Even if I only shrink the browser window (so it's not maximalized), I can't reproduce the error.
= The error can be reproduced only on maximalized browser window without firebug or chromium console opened.
Comment 9 Viliam Rockai 2012-09-13 11:39:10 EDT
Created attachment 612496 [details]
error screenshot
Comment 10 Viliam Rockai 2012-09-13 11:40:13 EDT
Created attachment 612497 [details]
DEBUG level server.log
Comment 11 Viliam Rockai 2012-09-13 11:46:47 EDT
Yes, local [browser, server, agent, EAP/EPP]
Comment 12 Mike Foley 2012-09-13 14:03:28 EDT
based on comment #11, related issue is https://bugzilla.redhat.com/show_bug.cgi?id=808548

which might explain why jshaugn and myself did not repro the error from our brosers.
Comment 13 Larry O'Leary 2012-11-05 17:11:24 EST
This appears to be related or caused by Bug 851288 and is a result of a UI rendering issue.
Comment 14 Larry O'Leary 2013-08-09 11:46:32 EDT

*** This bug has been marked as a duplicate of bug 851288 ***

Note You need to log in before you can comment on or make changes to this bug.