Bug 851336 - The 'closest mirror' option for installation source doesn't work if manually selected, since anaconda 18.6.1
The 'closest mirror' option for installation source doesn't work if manually ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 858039 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 16:37 EDT by Adam Williamson
Modified: 2012-11-22 20:09 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 20:09:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-23 16:37:27 EDT
The reproducer for this is simply to boot from a netinst.iso, go into the 'Installation Source' spoke, change nothing - leaving the drop-down menu at its default 'Closest mirror' setting - and return to the hub.

On Alpha TC3 - with anaconda 18.6 - this behaves as expected. I boot to the hub, wait while it sorts itself out, and it shows 'Closest mirror' as the Installation Source. If I then go into the Installation Source spoke and return to the hub, as described, it does just what you'd expect - nothing changes, 'Closest mirror' is shown as the source, no error triangle.

On the pre-TC4 build tflink made - http://imagebuilder.fedoraproject.org/testimage/18/pretc4/20120822_f18alpha_pretc4.x64.iso - which includes anaconda 18.6.1, this is broken. When you boot to the hub and just leave it sitting there, the 'Installation Source' is listed as 'Closest mirror', with no error triangle - but if you go into the Installation Source spoke and leave it again with the drop-down set to 'Closest mirror', then the hub changes so Installation Source is listed as 'Failed to set up install source' with an error triangle, and Software Selection shows 'Installation source not set up'.

I wonder if this is somehow related to the traceback tflink sees when trying to actually proceed with a default 'Closest mirror' install - https://bugzilla.redhat.com/show_bug.cgi?id=851274 .
Comment 1 lcarlon 2012-09-28 01:34:53 EDT
*** Bug 858039 has been marked as a duplicate of this bug. ***
Comment 2 Adam Williamson 2012-11-22 20:09:30 EST
Pretty sure this is fixed by now.

Note You need to log in before you can comment on or make changes to this bug.