This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 851342 - autopartitioning doesn't work in anaconda 18.6.1 (text mode/ppc64)
autopartitioning doesn't work in anaconda 18.6.1 (text mode/ppc64)
Status: CLOSED DUPLICATE of bug 848173
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
powerpc Linux
urgent Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-23 17:09 EDT by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 15:34:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (10.82 KB, text/plain)
2012-08-23 17:09 EDT, David Aquilina
no flags Details
storage.log (603.77 KB, text/plain)
2012-08-23 17:10 EDT, David Aquilina
no flags Details
program.log (164.27 KB, text/plain)
2012-08-23 17:25 EDT, David Aquilina
no flags Details
packaging.log (1.19 KB, text/plain)
2012-08-23 17:27 EDT, David Aquilina
no flags Details

  None (edit)
Description David Aquilina 2012-08-23 17:09:21 EDT
Description of problem:

It appears autopartitioning does not work in text mode on ppc64. When attempting to complete step 2 ("Installation Destination"), after selecting the appropriate options it returns an error stating "Error checking storage configuration". This occurs with both the "Use All Space" and "Replace Existing Linux system(s)" options. 

anaconda.log contains the following: 

20:06:24,210 ERR anaconda: You have not defined a root partition (/), which is required for installation of Fedora to continue.
20:06:24,211 ERR anaconda: you have not created a bootloader stage1 target device
20:06:24,212 ERR anaconda: You have not created a bootable partition.

(full logs will be attached)

Version-Release number of selected component (if applicable):

The ISO was built with: 

anaconda-18.6.1-1.fc18.ppc64
pungi-2.11-3.fc18.noarch
lorax-18.14-1.fc18.ppc64
yum-3.4.3-32.fc18.noarch
Comment 1 David Aquilina 2012-08-23 17:09:53 EDT
Created attachment 606708 [details]
anaconda log
Comment 2 David Aquilina 2012-08-23 17:10:17 EDT
Created attachment 606709 [details]
storage.log
Comment 3 Jesse Keating 2012-08-23 17:24:27 EDT
Can you attach the other log files too?  program.log etc..  Might not be necessary but it would be good to have a whole picture of what's going on.

What is the storage available on this system?  How did you boot the installer?
Comment 4 David Aquilina 2012-08-23 17:25:58 EDT
Created attachment 606710 [details]
program.log
Comment 5 David Aquilina 2012-08-23 17:27:13 EDT
Created attachment 606711 [details]
packaging.log
Comment 6 David Aquilina 2012-08-23 17:32:03 EDT
(In reply to comment #3)
> What is the storage available on this system?  How did you boot the
> installer?

It has a single 50G disk on /dev/sda. DVD iso is in /dev/sr0 which we booted off of with just 'linux'. There is no graphics hardware, so it defaulted to text mode.
Comment 8 Jesse Keating 2012-08-23 17:59:24 EDT
So the first screen of the installation destination spoke presented you a choice of drives, you picked the option to choose /dev/sda ?
Comment 9 David Aquilina 2012-08-24 00:03:32 EDT
Correct; after selecting it sda had a check next to it, then I hit 'c' to continue onto partitioning.
Comment 10 Jesse Keating 2012-08-24 14:28:05 EDT
Ok, I think this is something specific to PPC, or something specific to having LVM data on the disk before hand.

Can you blank the disks, like really blank the disks so that there is no LVM bits left and try again?
Comment 11 David Lehman 2012-08-24 15:34:36 EDT
This is caused by 848173. When that works, so will this.

*** This bug has been marked as a duplicate of bug 848173 ***
Comment 12 Mark Hamzy 2012-08-24 16:27:08 EDT
I have verified that this works when the patch in 848173 has been applied...

Note You need to log in before you can comment on or make changes to this bug.