Bug 851510 - failed dependency error in "software selection" remains
failed dependency error in "software selection" remains
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 07:58 EDT by Jan Sedlák
Modified: 2012-10-15 07:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 07:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2012-08-24 07:58:10 EDT
Description of problem:
When selecting software in "software selection", if you choose any Desktop group with some broken dependency, error from this remains even after you select different Desktop group.

How reproducible:
always

Steps to Reproduce:
1. Click on "software selection", select group with broken dependency (Gnome)
2. Click on "back", wait until dependencies are resolved, showing error
3. Click on "software selection" again, select group without broken dependency (Base for example)
4. Click "back" again, wait until dependencies are resolved
  
Actual results:
It shows "error checking software selection"

Expected results:
It shouldn't show any error

Additional info:
It still shows "gnome-shell requires libcamel..." even if I have chosen different desktop.
Comment 1 Jan Sedlák 2012-08-28 05:13:43 EDT
Changed from component Anaconda to component evolution-data-server, since "libcamel" comes from this package. Problem is in Fedora 18 Alpha TC3, during instalation by anaconda.
Comment 2 Jan Sedlák 2012-08-28 05:19:11 EDT
Proposing as blockerbug by criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
Comment 3 Jan Sedlák 2012-08-28 05:29:08 EDT
These are basically two bugs - I'm changing component back to anaconda - bug with remaining dependency errors even when you change group. Bug with unresolved dependency on libcamel (and proposed blockerbug) is now bug 852360.
Comment 4 Jan Sedlák 2012-10-15 07:09:45 EDT
I don't know how to test it when all dependencies are resolved, but since no-one bumped into this one recently, I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.