Bug 8516 - Installation problem with ET4000W32P video card
Installation problem with ET4000W32P video card
Status: CLOSED DUPLICATE of bug 7322
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-16 12:56 EST by s.guidi
Modified: 2015-01-07 18:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 16:46:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description s.guidi 2000-01-16 12:56:49 EST
Hello,
I have a problem during installation of RedHat 6.1
on a P100 machine, 32Mb RAM, 2 * 4.3Gb HD and
an ET4000W32P video card.
It doesn't matter if I boot from CD, from boot floppy
made from CD or from boot floppy downloaded from
RedHat site, the problem always appears.
If I boot in expert mode, after saying "No additional
device drivers", here is what happens:

Probing for mouse type...
Traceback (innermost last):
   File "/usr/bin/anaconda", line 133, in ?
      result = xserver.startX ()
   File "/usr/lib/python1.5/site-packages/xserver.py", line 44, in startX
      x.probe()
   File "/usr/lib/python1.5/site-packages/xf86config.py", line 170, in
probe
      self.vidCards.append(self.cards(server[5:]))
   File "/usr/lib/python1.5/site-packages/xf86config.py", line 118, in
cards
      card = cards[thecard]
KeyError: ET4000 W32i
Install exited abnormally
etc...

I thought it was a problem with the video card, so I tried
the text mode installation typing "text" at the boot prompt,
but after I choose all the packages to be installed, here is
the problem again (slightly different in the first rows,
but it should be the same problem):

Probing for mouse type...
Traceback (innermost last):
   File "/usr/bin/anaconda", line 255, in ?
      intf.run(todo, test = test)
   File "/usr/lib/python1.5/site-packages/text.py", line 1000, in run
      rc = apply(step[1](), step[2])
   File "/usr/lib/python1.5/site-packages/text.py", line 473, in __call__
      todo.x.probe (probeMonitor = 0)
   File "/usr/lib/python1.5/site-packages/xf86config.py", line 170, in
probe
      self.vidCards.append(self.cards(server[5:]))
   File "/usr/lib/python1.5/site-packages/xf86config.py", line 118, in
cards
      card = cards[thecard]
KeyError: ET4000 W32i

If I debug the xf86config.py at line 118, the command

(Pdb): p thecard         --> gives 'ET4000 W32i'
(Pdb): p card            --> gives {'END':'','':''}
(Pdb): p cards           --> gives some screens full of strings
(Pdb): p cards[thecard]  --> gives ***KeyError: <exceptions.KeyError
instance at 8be1b88>

How can I solve it ?
Why it detects an ET4000W32i instead of an ET4000W32P (does it matter ?)
Is there a way to skip the detection of the video card
and finish the installation at least in text mode ?

Thank you
S.Guidi
s.guidi@technologist.com
Comment 1 Michael Fulbright 2000-02-23 16:46:59 EST
*** This bug has been marked as a duplicate of 7322 ***

Note You need to log in before you can comment on or make changes to this bug.