Bug 851648 - parseCssLine Segmentation fault.
parseCssLine Segmentation fault.
Status: CLOSED DUPLICATE of bug 852101
Product: Fedora
Classification: Fedora
Component: ctags (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 11:20 EDT by Sami Farin
Modified: 2012-11-15 09:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 09:34:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2012-08-24 11:20:33 EDT
Description of problem:
"ctags -R ." command segfaults (chrome git repository).

Program received signal SIGSEGV, Segmentation fault.
(gdb) bt
#0  0x000000000040aff5 in parseCssLine (line=0x1 <Address 0x1 out of bounds>, state=P_STATE_AT_END) at css.c:110
#1  0x000000000040b027 in findCssTags () at css.c:210
#2  0x0000000000421cd9 in createTagsForFile (fileName=0x6bcde0 "chrome/browser/resources/extensions/pack_extension_overlay.css", language=10, passCount=1) at parse.c:617
#3  0x0000000000421dac in createTagsWithFallback (fileName=0x6bcde0 "chrome/browser/resources/extensions/pack_extension_overlay.css", language=10) at parse.c:639
#4  0x0000000000421e80 in parseFile (fileName=0x6bcde0 "chrome/browser/resources/extensions/pack_extension_overlay.css") at parse.c:666
#5  0x000000000041a582 in createTagsForEntry (entryName=0x6bcde0 "chrome/browser/resources/extensions/pack_extension_overlay.css") at main.c:303
#6  0x000000000041a3d2 in recurseUsingOpendir (dirName=0x6bd140 "chrome/browser/resources/extensions") at main.c:161
#7  0x000000000041a48c in recurseIntoDirectory (dirName=0x6bd140 "chrome/browser/resources/extensions") at main.c:258
#8  0x000000000041a54e in createTagsForEntry (entryName=0x6bd140 "chrome/browser/resources/extensions") at main.c:299
#9  0x000000000041a3d2 in recurseUsingOpendir (dirName=0x6c0920 "chrome/browser/resources") at main.c:161
#10 0x000000000041a48c in recurseIntoDirectory (dirName=0x6c0920 "chrome/browser/resources") at main.c:258
#11 0x000000000041a54e in createTagsForEntry (entryName=0x6c0920 "chrome/browser/resources") at main.c:299
#12 0x000000000041a3d2 in recurseUsingOpendir (dirName=0x6a4390 "chrome/browser") at main.c:161
#13 0x000000000041a48c in recurseIntoDirectory (dirName=0x6a4390 "chrome/browser") at main.c:258
#14 0x000000000041a54e in createTagsForEntry (entryName=0x6a4390 "chrome/browser") at main.c:299
#15 0x000000000041a3d2 in recurseUsingOpendir (dirName=0x69bc40 "chrome") at main.c:161
#16 0x000000000041a48c in recurseIntoDirectory (dirName=0x69bc40 "chrome") at main.c:258
#17 0x000000000041a54e in createTagsForEntry (entryName=0x69bc40 "chrome") at main.c:299
#18 0x000000000041a3d2 in recurseUsingOpendir (dirName=0x7fffffffd550 ".") at main.c:161
#19 0x000000000041a48c in recurseIntoDirectory (dirName=0x7fffffffd550 ".") at main.c:258
#20 0x000000000041a54e in createTagsForEntry (entryName=0x7fffffffd550 ".") at main.c:299
#21 0x000000000041a5c7 in createTagsForArgs (args=0x64c120) at main.c:348
#22 0x000000000041aafb in makeTags (args=0x64c120) at main.c:494
#23 0x000000000041ac98 in main (argc=3, argv=0x7fffffffcf80) at main.c:562
(gdb) frame 1
#1  0x000000000040b027 in findCssTags () at css.c:210
210	    state = parseCssLine( line, state );
(gdb) p line
$1 = (const unsigned char *) 0x6a6160 ""
(gdb) p state
$2 = P_STATE_NONE
(gdb) 


Version-Release number of selected component (if applicable):
5.8-7

How reproducible:
100%

Steps to Reproduce:
1. ctags -R .
2.
3.
  
Actual results:
segfault

Expected results:
no segfault

Additional info:

gcc version 4.7.1 20120813 (Red Hat 4.7.1-7) (GCC)
Comment 1 Ngo Than 2012-11-15 09:34:07 EST

*** This bug has been marked as a duplicate of bug 852101 ***

Note You need to log in before you can comment on or make changes to this bug.