Bug 852101 - [abrt] ctags-5.8-7.fc17: parseCssLine: Process /usr/bin/ctags was killed by signal 11 (SIGSEGV)
[abrt] ctags-5.8-7.fc17: parseCssLine: Process /usr/bin/ctags was killed by s...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ctags (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:81d2d3e05d7d27681a4cf16545d...
:
: 851648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 11:48 EDT by Peng Huang
Modified: 2012-12-04 00:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 22:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (4.44 KB, text/plain)
2012-08-27 11:48 EDT, Peng Huang
no flags Details
File: backtrace (16.97 KB, text/plain)
2012-08-27 11:48 EDT, Peng Huang
no flags Details
css file causes the cash (786 bytes, text/css)
2012-09-19 11:29 EDT, Peng Huang
no flags Details

  None (edit)
Description Peng Huang 2012-08-27 11:48:33 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        ctags -R base/ chrome content/ sandbox/
crash_function: parseCssLine
executable:     /usr/bin/ctags
kernel:         3.5.1-1.fc17.x86_64
pid:            8231
pwd:            /home/penghuang/sources/chromium/src
remote_result:  NOTFOUND
time:           Thu 23 Aug 2012 02:03:43 PM EDT
uid:            1000
username:       penghuang

backtrace:      Text file, 17379 bytes
environ:        Text file, 4550 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/penghuang/2

comment:
:1. Download chromium source code by following http://dev.chromium.org/developers/how-tos/get-the-code
:2. execute `ctags -R base/ chrome content/ sandbox/` to build TAGS
:3. crash

core_backtrace:
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x8cd1 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x19e2b - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x14117 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x13ffa - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x14170 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x13ffa - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x14170 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x13ffa - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x14170 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x13ffa - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x14170 - [exe] -
:d93ca7e3e3a04bc1bcb3aa0d33ceedcea9fbeaa9 0x2540 - [exe] -

dso_list:
:/usr/bin/ctags ctags-5.8-7.fc17.x86_64 (Fedora Project) 1345472989
:/usr/lib64/ld-2.15.so glibc-2.15-56.fc17.x86_64 (Fedora Project) 1345472906
:/usr/lib64/libc-2.15.so glibc-2.15-56.fc17.x86_64 (Fedora Project) 1345472906

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 95823                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       95823                95823                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-00437000 r-xp 00000000 103:02 410564                            /usr/bin/ctags
:00636000-00637000 r--p 00036000 103:02 410564                            /usr/bin/ctags
:00637000-0063a000 rw-p 00037000 103:02 410564                            /usr/bin/ctags
:0063a000-0063d000 rw-p 00000000 00:00 0 
:007ba000-008dc000 rw-p 00000000 00:00 0                                  [heap]
:3c96200000-3c96220000 r-xp 00000000 103:02 414196                        /usr/lib64/ld-2.15.so
:3c9641f000-3c96420000 r--p 0001f000 103:02 414196                        /usr/lib64/ld-2.15.so
:3c96420000-3c96421000 rw-p 00020000 103:02 414196                        /usr/lib64/ld-2.15.so
:3c96421000-3c96422000 rw-p 00000000 00:00 0 
:3c96600000-3c967ac000 r-xp 00000000 103:02 414216                        /usr/lib64/libc-2.15.so
:3c967ac000-3c969ac000 ---p 001ac000 103:02 414216                        /usr/lib64/libc-2.15.so
:3c969ac000-3c969b0000 r--p 001ac000 103:02 414216                        /usr/lib64/libc-2.15.so
:3c969b0000-3c969b2000 rw-p 001b0000 103:02 414216                        /usr/lib64/libc-2.15.so
:3c969b2000-3c969b7000 rw-p 00000000 00:00 0 
:7f83b09bb000-7f83b0bbc000 rw-p 00000000 00:00 0 
:7f83b0bbc000-7f83b0dbd000 rw-p 00000000 00:00 0 
:7f83b0f80000-7f83b0f83000 rw-p 00000000 00:00 0 
:7f83b0fa7000-7f83b0faa000 rw-p 00000000 00:00 0 
:7fffde16e000-7fffde190000 rw-p 00000000 00:00 0                          [stack]
:7fffde1b3000-7fffde1b4000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/pts/2
:pos:	0
:flags:	0100002
:1:/dev/pts/2
:pos:	0
:flags:	0100002
:2:/dev/pts/2
:pos:	0
:flags:	0100002
:3:/usr/share/bash-completion/completions
:pos:	0
:flags:	0100000
:4:/home/penghuang/sources/chromium/src/tags
:pos:	24559391
:flags:	0100001
:5:/home/penghuang/sources/chromium/src/chrome
:pos:	9223372036854775807
:flags:	02304000
:6:/home/penghuang/sources/chromium/src/chrome/browser
:pos:	9223372036854775807
:flags:	02304000
:7:/home/penghuang/sources/chromium/src/chrome/browser/resources
:pos:	9223372036854775807
:flags:	02304000
:8:/home/penghuang/sources/chromium/src/chrome/browser/resources/extensions
:pos:	9223372036854775807
:flags:	02304000
:9:/home/penghuang/sources/chromium/src/chrome/browser/resources/extensions/pack_extension_overlay.css
:pos:	480
:flags:	0100000

var_log_messages:
:Aug 20 10:29:50 penghuang-goobuntu yum[27892]: Updated: ctags-5.8-7.fc17.x86_64
:Aug 23 14:03:43 penghuang-goobuntu kernel: [876126.202035] ctags[8231]: segfault at 1 ip 0000000000408cd1 sp 00007fffde18c740 error 4 in ctags[400000+37000]
:Aug 23 14:03:43 penghuang-goobuntu abrt[8239]: Saved core dump of pid 8231 (/usr/bin/ctags) to /var/spool/abrt/ccpp-2012-08-23-14:03:43-8231 (5668864 bytes)
Comment 1 Peng Huang 2012-08-27 11:48:36 EDT
Created attachment 607243 [details]
File: environ
Comment 2 Peng Huang 2012-08-27 11:48:38 EDT
Created attachment 607244 [details]
File: backtrace
Comment 3 Peng Huang 2012-09-19 10:55:00 EDT
This issue only happens in ctags-5.8-7.fc17.x86_64.

ctags-5.8-4.fc17.x86_64 does not have this issue.
Comment 4 Peng Huang 2012-09-19 11:29:55 EDT
Created attachment 614417 [details]
css file causes the cash
Comment 5 Peng Huang 2012-09-19 12:02:19 EDT
Below change can fix the issues. please check it. thanks.
$ diff -u css.c.old css.c
--- css.c.old	2012-09-19 11:53:06.301463638 -0400
+++ css.c	2012-09-19 11:58:14.588538427 -0400
@@ -73,10 +73,11 @@
   {
     if( (int) *cp == '\0' )
     { 
+      // assign position to the end of line.
+      *position = cp;
       cp = fileReadLine ();
       if( cp == NULL ){
         makeCssSimpleTag(name, kind, TRUE);
-        *position = cp;
         return P_STATE_AT_END;
       }
     }
Comment 6 Michael Stahl 2012-09-20 10:25:01 EDT
i've got the same crash on a CSS file here, the patch from comment #5 seems to fix it.
Comment 7 Peng Huang 2012-09-26 16:11:55 EDT
Ngo Than, kindly ping.
Comment 8 Ngo Than 2012-10-18 15:54:01 EDT
Peng, i will build new package with this fix for f17 and f18. Many thanks for the fix!
Comment 9 Ngo Than 2012-11-15 09:29:47 EST
it's fixed in ctags-5.8-9.fc17
Comment 10 Ngo Than 2012-11-15 09:34:07 EST
*** Bug 851648 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-11-15 09:38:32 EST
ctags-5.8-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ctags-5.8-9.fc16
Comment 12 Fedora Update System 2012-11-15 09:39:42 EST
ctags-5.8-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ctags-5.8-9.fc17
Comment 13 Fedora Update System 2012-11-15 09:42:37 EST
ctags-5.8-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ctags-5.8-9.fc18
Comment 14 Fedora Update System 2012-11-15 14:57:02 EST
Package ctags-5.8-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ctags-5.8-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18268/ctags-5.8-9.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-11-23 22:27:10 EST
ctags-5.8-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-11-23 22:30:12 EST
ctags-5.8-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-12-04 00:21:58 EST
ctags-5.8-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.