Bug 851733 - Fedora 16->17 upgrade left /boot empty
Fedora 16->17 upgrade left /boot empty
Status: CLOSED DUPLICATE of bug 804913
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 17:44 EDT by Roland Roberts
Modified: 2012-08-24 18:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 18:02:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Roberts 2012-08-24 17:44:58 EDT
Description of problem:
System was a fully up-to-date Fedora 16 system. 
After the upgrade, reboot fell into a dracut shell immediately after mounting the root filesystem. The last messages before getting a dracut prompt are:

 cannot find init!
 please check to make sure you specified a valid root filesystem!

At that point, the root file system IS mounted, but /boot is empty. Running "lvm vgscan -ay" to insure all volumes are activated is not helpful as exiting dracut still results in a kernel panic.

Version-Release number of selected component (if applicable):


How reproducible:

Don't know what triggered empty /boot. 

Steps to Reproduce:
1. "Normal" upgrade from F16->F17 via preupgrade
2.
3.
  
Actual results:


Expected results:


Additional info:

I have booted using live media and am trying to figure out a recovery strategy that doesn't involve copying my data to a new drive and installing clean :-(

parted shows the drive as having three partitions, bios_grub, boot, and lvm.
Comment 1 Roland Roberts 2012-08-24 17:48:31 EDT
Okay, it's not that /boot is empty, it's not being mounted at that point. It is present in the EFI partition and I can mount it. My misunderstanding.
Comment 2 Roland Roberts 2012-08-24 18:02:31 EDT
Okay, after continuing to browse, I realized this is actually a duplicate of 804913. The same solution works, adding rd.lvm.lv=vg_xyzzy/usr as I also have /usr as a separate partition.

*** This bug has been marked as a duplicate of bug 804913 ***

Note You need to log in before you can comment on or make changes to this bug.