Bug 851864 - Apper 0.8.0 displays wrong warning when no updates are available
Apper 0.8.0 displays wrong warning when no updates are available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 855509 (view as bug list)
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-08-26 13:54 EDT by Daniel Vrátil
Modified: 2015-11-01 20:36 EST (History)
8 users (show)

See Also:
Fixed In Version: apper-0.8.0-0.7.20121002git.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 10:40:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Vrátil 2012-08-26 13:54:02 EDT
Description of problem:
When there are no updates available after "Check for new updates", Apper displays warning about last check for updates being too long ago instead of information that no updates are available.

When there are updates available, updating all packages and clicking "Check for new updates" will result in displaying the wrong warning as well.


Version-Release number of selected component (if applicable):
apper-0.8.0-0.4.20120724git.fc18
packagekit-0.8.3-1.fc18
yum-3.4.3-33.fc18


How reproducible:
Always

Steps to Reproduce:
1. Install new system from network (so that it's up to date)
2. Start Apper
3. Click "Check for new Updates"
4. Wait for it to finish checking

Alternative steps to reproduce:
1. Downgrade any package
2. Start Apper
3. Click "Check fo new Updates"
4. Install available updates
5. Click "Check for new Updates" again
  
Actual results:
Apper says "Last check for updates was more then a month ago. It's strongly recommended that you check for new updates now"


Expected results:
Apper should say "No updates available"

Additional info:
This is a clean net-installation of Fedora 18 Alpha-TC3 with KDE
Comment 1 Martin Krizek 2012-09-19 08:43:20 EDT
Confirmed on Fedora 18 Alpha (RC3), proposing as NTH as the warning is confusing -- user might read it as "no check for updates was done".
Comment 2 Rex Dieter 2012-10-02 14:55:47 EDT
*** Bug 855509 has been marked as a duplicate of this bug. ***
Comment 3 Martin Krizek 2012-10-11 07:16:19 EDT
This seems to be fixed on my system:

apper-0.8.0-0.6.20120724git.fc18
PackageKit-0.8.4-1.fc18
yum-3.4.3-45.fc18
Comment 4 Kevin Kofler 2012-10-11 10:38:02 EDT
Dan, can you also confirm that this is fixed, so we can close it?
Comment 5 Rex Dieter 2012-10-11 10:40:25 EDT
It's fixed for me too, I'll go ahead and close.  feel free to reopen if anyone does indeed still experience this after installing,
https://admin.fedoraproject.org/updates/FEDORA-2012-15375
Comment 6 Martin Kho 2012-10-11 11:10:33 EDT
Hi,

Yes, all messages are fine now. Just for my information: Is it right that 'logout' and 'reboot' instructions after e.g. kernel updates will be replaced by the new 'offline updates' feature?


Martin Kho
Comment 7 Kevin Kofler 2012-10-11 11:38:30 EDT
No.
Comment 8 Martin Kho 2012-10-11 12:00:03 EDT
Oh... Then I'll test a little further and see if reboot/logout instructions will ever appear. If not, I'll open a new report for that :-)

Thanks,

Martin Kho

Note You need to log in before you can comment on or make changes to this bug.