Bug 855509 - apper refuses to update: "Last check was more than a month ago"
apper refuses to update: "Last check was more than a month ago"
Status: CLOSED DUPLICATE of bug 851864
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 854209
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 06:58 EDT by Martin Kho
Modified: 2012-10-02 14:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 14:55:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2012-09-08 06:58:58 EDT
Description of problem:
When updates are available apper seems to check when the cache was refreshed. If the last check was more than a month ago apper advises: "it's strongly recommended that you check for new updates now" Pressing the  button "Check for new updates" results in the same message.

It looks like that here is a problem with the communication between apper and PackageKit or PackageKit and dbus.

The following command always gives:

qdbus --system org.freedesktop.PackageKit /org/freedesktop/PackageKit org.freedesktop.PackageKit.GetTimeSinceAction refresh-cache

4294967295 (meaning not defined)

Version-Release number of selected component (if applicable):
* apper-0.8.0-0.4.20120724git.fc18.x86_64
* PackageKit-0.8.3-1.fc18.x86_64
* dbus-1.6.0-2.fc18.x86_64

* yum-3.4.3-42.fc18.noarch

How reproducible:
nearly always. I've seen once that a new check succeeded

Steps to Reproduce:
1. wait for updates
2. press "Apply"
3. the above message appears
4. press "Check for new Updates"
5. the above message appears (and see "How reproducible")
  
Actual results:
Updates will not be installed

Expected results:
Updates will be installed

Additional info:
Comment 1 Rex Dieter 2012-09-08 08:29:18 EDT
Pretty sure this is essentially a dup of bug #854209 and fixed by
https://admin.fedoraproject.org/updates/FEDORA-2012-13559/PackageKit-0.8.3-2.fc18
Comment 2 Martin Kho 2012-09-09 05:02:35 EDT
Hi Rex,

You're absolutly right! PackageKit-0.8.3-2 has also solved this issue. Please close this report.

Thanks,

Martin Kho
Comment 3 Martin Kho 2012-09-09 05:32:22 EDT
Hi,

Hmmm, the update went fine, but there is still something wrong. After the update apper gives the message:

"Last check was more than a month ago. it's strongly recommended that you check for new updates now"

and

qdbus --system org.freedesktop.PackageKit /org/freedesktop/PackageKit org.freedesktop.PackageKit.GetTimeSinceAction refresh-cache

gives 4294967295 (meaning not defined)

So please don't close this report.

Martin Kho
Comment 4 Martin Kho 2012-09-09 05:35:42 EDT
Hi,

... and there was a kernel update that normally requires a reboot. No request though.


Martin Kho
Comment 5 Martin Kho 2012-09-23 12:01:05 EDT
Hi,

In .xsession-errors I see:

packagekit-qt: "/2220_dacbdabd" 
Error, cannot create transaction proxy QDBusError("org.freedesktop.DBus.Error.NameHasNoOwner", "Could not get owner of name 'org.freedesktop.PackageKit': no such name") 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2221_bdeaacea" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2222_adcaeeed" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2223_beedaaed" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2224_dabbdebc" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2225_aeecddce" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2228_cdbaecdd" 
QDBusObjectPath: invalid path ""
packagekit-qt: "/2229_cdceaedd"

Martin Kho
Comment 6 Rex Dieter 2012-10-02 14:55:47 EDT

*** This bug has been marked as a duplicate of bug 851864 ***

Note You need to log in before you can comment on or make changes to this bug.