This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 85204 - Broken pipe when gathering files
Broken pipe when gathering files
Status: CLOSED DUPLICATE of bug 85209
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-26 12:06 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-02-26 12:06:28 EST
Description of problem:
When processing %files, get: "getOutputFrom(): Broken pipe"

Version-Release number of selected component (if applicable):
rpm version 4.1

How reproducible:
Very

Steps to Reproduce:
1. %files list w more than 46 file names; size of files irrelevant
2. rpmbuild -bb -vv arpa-3.1-4.spec

    
Actual results:
   .
   .
Checking for unpackaged files(): /usr/lib/rpm/check_files %{buildroot}
getOutputFrom(): Broken pipe
#

Expected results:
   .
   .
Checking for unpackaged files(): /usr/lib/rpm/check_files %{buildroot}
D: fini   100644     1 (    0,   0)  234  asdlkfh  etc
   .
   .
GZDIO: 34 writes,    4615548 total bytes in 0.088 secs
D: Signature: size(180)+pad(4)
Wrote:  /usr/src/redhat/RPMS/i386/arpa-3.1-4.i386.rpm
#


Additional info:
two *.spec files work fine w. rpm 4.0.4; same problem w. both
BuildRoot undefined (check-files doesn't do anything)
no %prep, %build, %install, or %clean
no files in %files have any file-related directives
file list works fine as input to cpio
seems to be related to number of files, not any particular file, contents or size
"default" RedHat 8.0 install
Comment 1 Jeff Johnson 2003-02-27 13:03:43 EST

*** This bug has been marked as a duplicate of 85209 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.