Bug 85209 - Broken pipe when gathering files
Summary: Broken pipe when gathering files
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 85204 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 17:39 UTC by Need Real Name
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-21 07:47:10 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-02-26 17:39:43 UTC
Description of problem:
When processing %files, get: "getOutputFrom(): Broken pipe"

Version-Release number of selected component (if applicable):
rpm version 4.1

How reproducible:
Very

Steps to Reproduce:
1. %files list w more than 46 file names; size of files irrelevant
2. rpmbuild -bb -vv arpa-3.1-4.spec

    
Actual results:
   .
   .
Checking for unpackaged files(): /usr/lib/rpm/check_files %{buildroot}
getOutputFrom(): Broken pipe
#

Expected results:
   .
   .
Checking for unpackaged files(): /usr/lib/rpm/check_files %{buildroot}
D: fini   100644     1 (    0,   0)  234  asdlkfh  etc
   .
   .
GZDIO: 34 writes,    4615548 total bytes in 0.088 secs
D: Signature: size(180)+pad(4)
Wrote:  /usr/src/redhat/RPMS/i386/arpa-3.1-4.i386.rpm
#


Additional info:
two *.spec files work fine w. rpm 4.0.4; same problem w. both
BuildRoot undefined (check-files doesn't do anything)
no %prep, %build, %install, or %clean
no files in %files have any file-related directives
file list works fine as input to cpio
seems to be related to number of files, not any particular file, contents or size
"default" RedHat 8.0 install

Comment 1 Jeff Johnson 2003-02-27 18:03:45 UTC
*** Bug 85204 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2003-03-05 03:05:47 UTC
Do you have a BuildRoot: directive?

If not, you should ;-)

Otherwise, disable check_files by adding to spec file
    %define __check_files %{nil}

Comment 3 Mats Westlund 2003-09-18 10:08:58 UTC
I have the same problem when building the Regina-REXX-3.2-1.src.rpm package
with rpmbuild -bb Regina-3.2.spec command but if I reboot the system the build
often works the first time but fail if I try to build it more than once. 
This is on the taroon-beta2 for s390


Note You need to log in before you can comment on or make changes to this bug.