Bug 852056 - RHEVM installation: The NFS share created but the setup script in not populated anymore with the tools ISO and VFD
RHEVM installation: The NFS share created but the setup script in not populat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Alon Bar-Lev
Pavel Stehlik
integration
: Regression
Depends On:
Blocks: 852060
  Show dependency treegraph
 
Reported: 2012-08-27 09:07 EDT by Simon Grinberg
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Grinberg 2012-08-27 09:07:37 EDT
Description of problem:

In 3.0 after creating the local nfs share it was populated with the virtio-win.vfd,  virtio-win.iso, and the rhev-tools iso. This fails to happen on 3.1


Version-Release number of selected component (if applicable):
SI15

Additional info:

The reason is that _loadFilesToIsoDomain function in /usr/share/ovirt-engine/scripts/engine-setup.py is not called anymore. When adding the call this works as expected.
Comment 2 Alon Bar-Lev 2012-08-29 06:26:13 EDT
commit 4c1c7e59be155d5872517e026fbc55bb524b1d8e
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Wed Aug 29 12:20:52 2012 +0300

    packaging: populate iso domain to nfs share (#852056)
    
    Regression since 3.0.
    
    Was removed during:
    
    6250645 Packaging: Update configuration in logcollector and isouploader (#784303)
    
    Change-Id: I55abba4831aafc129e0d0b96be9429237c924f95
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

http://gerrit.ovirt.org/#/c/7565/
Comment 5 Pavel Stehlik 2012-09-13 10:34:26 EDT
ok - si18

Note You need to log in before you can comment on or make changes to this bug.