Bug 852060 - rhevm installation: Add a warning if virtio-win.vfd failed to be copied to the local nfsshare
rhevm installation: Add a warning if virtio-win.vfd failed to be copied to th...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Alex Lourie
Haim
integration
:
Depends On: 852056
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 09:19 EDT by Simon Grinberg
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version: si-20
Doc Type: Release Note
Doc Text:
The rhevm package now depends on the virtio-win package. This package is available in the RHEL Server Supplementary (v. 6 64-bit x86_64) channel, also referred to by the identifier rhel-x86_64-server-supplementary-6.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-24 04:49:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Grinberg 2012-08-27 09:19:40 EDT
Description of problem:

In 3.0 after virtio-win was a dependency of rhevm. Now that it was moved to 
rhel-x86_64-server-supplementary-6 this dependency was removed. 

This means that after fixing bug 852056, the virtio-win VFD and ISO will still fail copy to the local ISO share if the user did not:
1. Added rhel-x86_64-server-supplementary-6 to the registered channel 
2. yum install virtio-win

Since we don't want to force dependency of rhevm on virtio-win nor do we want to fail the setup on this, in case the files are missing the setup script should refer the customers to the installation guide for details on how to install und upload after the setup is complete. 

Version-Release number of selected component (if applicable):
SI15
Comment 1 Simon Grinberg 2012-08-27 09:25:22 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On the rhevm setup section need to add the supplementary channel and a step to install the virtio. (For those who intend to use windows VMs and use the locally created NFS)

On the iso-uploader section need to add the supplementary channel before the instructions for uploading the virtio-win files.
Comment 3 Itamar Heim 2012-08-27 09:38:23 EDT
simon, why don't we want to require this rpm? ship it also in rhev channel if relevant, but i don't see a use case in which it is not releavnt to rhev customers?
Comment 4 Simon Grinberg 2012-08-27 10:30:33 EDT
(In reply to comment #3)
> simon, why don't we want to require this rpm? ship it also in rhev channel

If it's possible to have it in both channel then I don't mind. 

> if relevant, but i don't see a use case in which it is not relevant to rhev
> customers?

For customers not using Windows at all it's relevant. But I agree they are probably not the majority. 

Andy, how do you think about duplicating this package to the RHEV channel?
(Another alternative it to enforce the supplementary channel and have rhevm require virtio-win as before)
Comment 5 Itamar Heim 2012-08-27 10:57:32 EDT
I'm for KISS and require this package from rhev-m spec perspective
Comment 17 Leonid Natapov 2012-11-18 11:12:39 EST
si24.2 partially fixed.
There is an error message in the installation log file but user has no indication that something went wrong,so no reason to look in the installation log file. The error message regarding missing files/copy failure has to appear on the console while installation.

This is the output from installation log file:
-------------
2012-11-18 17:33:25::DEBUG::common_utils::341::root:: stderr =
2012-11-18 17:33:25::DEBUG::common_utils::342::root:: retcode = 0
2012-11-18 17:33:25::DEBUG::nfsutils::145::root:: refreshing NFS exports
2012-11-18 17:33:25::DEBUG::setup_sequences::59::root:: running _loadFilesToIsoDomain
2012-11-18 17:33:25::ERROR::rhevm-setup::1633::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-setup", line 1630, in _loadFilesToIsoDomain
    utils.copyFile(filename, targetPath, basedefs.CONST_VDSM_UID, basedefs.CONST_KVM_GID)
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 577, in copyFile
    shutil.copy2(fileSrc, destination)
  File "/usr/lib64/python2.6/shutil.py", line 95, in copy2
    copyfile(src, dst)
  File "/usr/lib64/python2.6/shutil.py", line 50, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: '/usr/share/virtio-win/virtio-win.vfd'

2012-11-18 17:33:25::ERROR::rhevm-setup::1634::root:: Failed to copy files to iso domain
---------------
Comment 18 Itamar Heim 2012-11-19 05:51:30 EST
since this requires user to cause an integrity to another required rpm, postponing the handling of this.
this is not a regression - the regression was fixed by adding the dependnecy on the virtio-win rpm.

Note You need to log in before you can comment on or make changes to this bug.