Bug 852223 - IE8 rendering of resource measurement time overlaid on the actual metric name
IE8 rendering of resource measurement time overlaid on the actual metric name
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.1
Unspecified Windows
medium Severity medium
: ---
: JON 3.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
: Reopened
Depends On: 848501
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 18:08 EDT by Mike Thompson
Modified: 2014-08-27 17:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 848501
Environment:
Last Closed: 2014-08-27 17:20:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Firefox screenshot (147.16 KB, image/png)
2012-09-03 09:17 EDT, Filip Brychta
no flags Details
IE screenshot (70.45 KB, image/png)
2012-09-03 09:18 EDT, Filip Brychta
no flags Details

  None (edit)
Description Mike Thompson 2012-08-27 18:08:17 EDT
+++ This bug was initially created as a clone of Bug #848501 +++

Created attachment 604668 [details]
ie8 metric value overlaying text

Description of problem:
This is an IE8 bug where the metric values overlay the metric name in IE8.


How reproducible:
Always

Steps to Reproduce:
Go to a resource summary page (with the sparkline thumbnail graphs)

/coregui/#Resource/10002/Summary/Activity


The metric values should not overlay the text.

NOTE: this brought in by the fix: 
https://bugzilla.redhat.com/show_bug.cgi?id=825230
and is in JON3.1.1.

--- Additional comment from mithomps@redhat.com on 2012-08-15 15:23:02 EDT ---

Created attachment 604674 [details]
ie9 Windows 7

--- Additional comment from mithomps@redhat.com on 2012-08-15 15:24:49 EDT ---

Confirmed on Windows 7 IE9 as well.

css incompatibility.

--- Additional comment from ccrouch@redhat.com on 2012-08-15 15:49:07 EDT ---

Assigning to Mike to investigate for jon311

(2:48:12 PM) ccrouch: mtho11: yes please investigate, and assuming the change is super easy and safe and doesnt impact our other supported browsers, then lets target it, but lets make sure its gets reviewed

--- Additional comment from mithomps@redhat.com on 2012-08-27 11:27:39 EDT ---

*** Bug 850852 has been marked as a duplicate of this bug. ***

--- Additional comment from mithomps@redhat.com on 2012-08-27 17:55:50 EDT ---

After some fiddling I came up with a simple one line solution that works across all browsers and is low risk.

Master commit ID: f3f26d0
Comment 1 Mike Thompson 2012-08-28 10:52:44 EDT
release/jon3.1.x commit id: 86c4226

From original BZ: https://bugzilla.redhat.com/show_bug.cgi?id=848501
Comment 2 John Sanda 2012-08-29 21:40:12 EDT
The CR1 build is available at
https://brewweb.devel.redhat.com/buildinfo?buildID=231258. Moving to ON_QA.
Comment 3 Filip Brychta 2012-09-03 09:17:05 EDT
Bug is fixed for big sized windows, but remains for smaller windows using IE (when side bar is displayed).See attached pictures. It's working correctly even for small windows in firefox.
Comment 4 Filip Brychta 2012-09-03 09:17:31 EDT
Created attachment 609383 [details]
Firefox screenshot
Comment 5 Filip Brychta 2012-09-03 09:18:07 EDT
Created attachment 609384 [details]
IE screenshot
Comment 6 Mike Foley 2012-09-04 14:10:28 EDT
triaging to 3.1.2 (call with crouch, myarboro, mfoley)
Comment 7 Charles Crouch 2012-09-10 16:22:34 EDT
Setting to medium, per today's triage.
Comment 9 Mike Thompson 2014-08-27 17:20:27 EDT
There have been changes to the layout on that screen so it might even work now. But this is a IE8 bug and since we have moved JON3.3.0 to minimal browser requirements of IE9.

Note You need to log in before you can comment on or make changes to this bug.