Bug 852240 - yum doesn't merge/generate comps environment data
yum doesn't merge/generate comps environment data
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 852050 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-27 21:04 EDT by Jesse Keating
Modified: 2014-01-21 18:23 EST (History)
12 users (show)

See Also:
Fixed In Version: yum-3.4.3-36.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-31 02:45:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2012-08-27 21:04:49 EDT
New comps metadata exists, environment.  Pungi does not appear to take this metadata into account and merge it into the comps it uses for group metadata for it's compose (and in particular the DVD).  This leads to a blank software spoke.
Comment 1 Jesse Keating 2012-08-27 21:05:29 EDT
Also note that if there is a blank software selection spoke, the spoke is considered "incomplete", which means installation cannot proceed.
Comment 2 Adam Williamson 2012-08-27 21:07:43 EDT
Proposing as Alpha blocker: this violates criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".
Comment 3 Jesse Keating 2012-08-28 15:36:22 EDT
Tracked this down to a yum issue, patch generated and submitted.  http://lists.baseurl.org/pipermail/yum-devel/2012-August/009536.html
Comment 4 Jesse Keating 2012-08-29 12:30:43 EDT
*** Bug 852050 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2012-08-29 12:33:13 EDT
Discussed at 2012-08-29 blocker review meeting. Accepted as a blocker per criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".
Comment 6 Bill Nottingham 2012-08-29 17:46:34 EDT
This does raise another question - where does this merged comps file end up? Is it also dropping all anaconda whitelist/blacklist, and langpack info?
Comment 7 Jesse Keating 2012-08-29 17:59:56 EDT
(In reply to comment #6)
> This does raise another question - where does this merged comps file end up?
> Is it also dropping all anaconda whitelist/blacklist, and langpack info?

The merged comps gets written out and used to generate the repodata on the DVD and in the Fedora/os/ directory created by the pungi run.

I have no idea about the whitelist/blacklist or langpack data.  Is there examples of this in the comps file in git?
Comment 8 Bill Nottingham 2012-08-30 03:19:16 EDT
See the 'langpacks', 'whiteout', and 'blacklist' sections at the end of comps-XYZ.xml(.in). And yes, I've confirmed they are missing in the 'Fedora' tree (and presumably the DVD) while existing in the 'Everything' tree.
Comment 9 Fedora Update System 2012-08-30 10:52:31 EDT
yum-3.4.3-39.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-12900/yum-3.4.3-39.fc18
Comment 10 Jesse Keating 2012-08-30 11:39:53 EDT
(In reply to comment #8)
> See the 'langpacks', 'whiteout', and 'blacklist' sections at the end of
> comps-XYZ.xml(.in). And yes, I've confirmed they are missing in the 'Fedora'
> tree (and presumably the DVD) while existing in the 'Everything' tree.

So the fix for getting environment stuff was in yum itself, in the comps.py Comps.write() method.  Most the wiring was there for it, just needed to be hooked up.  Question is, does the wiring exist for the other items, or is this going to be a much bigger task...

A quick git grep shows that yum doesn't really have much info at all on langpack, whiteout, or blacklist, at least in relation to comps.  Time for a new bug I guess.
Comment 11 Fedora Update System 2012-08-31 02:45:09 EDT
yum-3.4.3-40.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.